Bug 133659 - after uninstalling and removing the /etc/samba directory it will not run after reinstalling
after uninstalling and removing the /etc/samba directory it will not run afte...
Status: CLOSED DUPLICATE of bug 128245
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-25 16:53 EDT by John Poelstra
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full strace (49.31 KB, text/plain)
2004-09-25 16:55 EDT, John Poelstra
no flags Details

  None (edit)
Description John Poelstra 2004-09-25 16:53:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
I uninstalled system-config-samba and the other samba rpm's.  Then I
removed the /etc/samba directory.  Next I reinstalled all of the samba
packages and attempted to run system-config-samba.  It won't run and
gives me an error message:

# system-config-samba
Traceback (most recent call last):
  File "/usr/share/system-config-samba/system-config-samba.py", line
38, in ?
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/system-config-samba/mainWindow.py", line 75, in
__init__
    self.samba_data = sambaParser.SambaParser(self)
  File "/usr/share/system-config-samba/sambaParser.py", line 40, in
__init__
    self.parseFile()
  File "/usr/share/system-config-samba/sambaParser.py", line 71, in
parseFile
    token = self.createToken(line)
  File "/usr/share/system-config-samba/sambaParser.py", line 143, in
createToken    token =
sambaToken.SambaToken(sambaToken.SambaToken.SAMBA_TOKEN_KEYVAL, (name,
value), self.parent)
  File "/usr/share/system-config-samba/sambaToken.py", line 36, in
__init__
    raise AttributeError, value
AttributeError: ('cups options', 'raw')




Version-Release number of selected component (if applicable):
system-config-samba-1.2.9-2

How reproducible:
Always

Steps to Reproduce:
1. I can't reproduce it because I can't resolve this problem
2.
3.
    

Additional info:

rpm -qa | grep samba
samba-client-3.0.7-2.FC2
system-config-samba-1.2.9-2
samba-3.0.7-2.FC2
samba-common-3.0.7-2.FC2
samba-swat-3.0.7-2.FC2
Comment 1 John Poelstra 2004-09-25 16:55:09 EDT
Created attachment 104324 [details]
full strace
Comment 2 Nils Philippsen 2004-09-25 17:03:52 EDT
Fixed in 1.2.15-0.fc2.1 in testing.

*** This bug has been marked as a duplicate of 128245 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.