Bug 133692 - missing dep: glibc-common for pkg glibc
missing dep: glibc-common for pkg glibc
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-26 09:22 EDT by Bernhard Erdmann
Modified: 2014-01-21 17:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 15:07:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/yum.conf (913 bytes, text/plain)
2004-09-29 17:26 EDT, Bernhard Erdmann
no flags Details
/etc/yum.conf with only one mirror an enabling glibc*-updates (907 bytes, text/plain)
2004-09-29 17:35 EDT, Bernhard Erdmann
no flags Details
yum debug file (3.51 KB, text/plain)
2004-09-30 06:17 EDT, Bernhard Erdmann
no flags Details
yum debug log after deleting /var/cache/yum/* (1.78 KB, text/plain)
2004-09-30 09:08 EDT, Bernhard Erdmann
no flags Details

  None (edit)
Description Bernhard Erdmann 2004-09-26 09:22:53 EDT
Description of problem:

yum reports
Error: missing dep: glibc-common for pkg glibc


Version-Release number of selected component (if applicable):
yum-2.1.3-1

How reproducible:
every time

Steps to Reproduce:
1. yum -y update
2.
3.
  
Actual results:
# yum -y update
Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3500/3500
Excluding Packages
Excluding Incompatible Archs
Finished
Excluding Packages from Fedora Core 2.91 - Development Tree
Resolving Dependencies
Error: missing dep: glibc-common for pkg glibc


Expected results:


Additional info:
Comment 1 Seth Vidal 2004-09-26 11:46:00 EDT
This is a distribution bug, not a yum bug.
Comment 2 Bill Nottingham 2004-09-28 22:40:23 EDT
Does this persist? What arch are you using?
Comment 3 Bernhard Erdmann 2004-09-29 14:58:27 EDT
Arch is i386
It does still persist.
Comment 4 Seth Vidal 2004-09-29 16:05:29 EDT
run this command:
rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}\n" | grep glibc

And show us the output, please.

Comment 5 Bill Nottingham 2004-09-29 16:09:35 EDT
Does the file exist in your mirror?
Comment 6 Bernhard Erdmann 2004-09-29 16:57:51 EDT
# rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}\n" | grep glibc
glibc-2.3.3-53.i686
glibc-headers-2.3.3-53.i386
glibc-common-2.3.3-53.i386
glibc-kernheaders-2.4-9.1.87.i386
glibc-devel-2.3.3-53.i386

Comment 7 Bernhard Erdmann 2004-09-29 16:59:46 EDT
The file glibc-common-2.3.3-59.i386.rpm does exist on the mirror:
http://wftp.tu-chemnitz.de/pub/linux/fedora-core/development/i386/Fedora/RPMS/glibc-common-2.3.3-59.i386.rpm
Comment 8 Bill Nottingham 2004-09-29 17:23:01 EDT
Please attach your /etc/yum.conf.
Comment 9 Bernhard Erdmann 2004-09-29 17:26:12 EDT
Created attachment 104551 [details]
/etc/yum.conf
Comment 10 Seth Vidal 2004-09-29 17:27:25 EDT
you're excluding glibc in the top of your yum.conf.

Comment 11 Bernhard Erdmann 2004-09-29 17:29:42 EDT
glic* was excluded to upgrade all other packages
if I include glibc*, yum reports the error described
Comment 12 Bill Nottingham 2004-09-29 17:31:47 EDT
What happens if you use only one site?

It looks like version skew between the repo data and the tree.
Comment 13 Bernhard Erdmann 2004-09-29 17:34:27 EDT
the same error occurs if I disable the wftp.tu-chemnitz.de-mirror and
enable glibc*-upgrades

# yum -y update
Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB   
00:00 
Reading repository metadata in from local files
developmen: ################################################## 3441/3441
Excluding Packages in global exclude list
Finished
Resolving Dependencies
Processing Dependency: glibc-common= 2.3.3-53 for package: glibc
Finished Dependency Resolution
Error: missing dep: glibc-common for pkg glibc
Comment 14 Bernhard Erdmann 2004-09-29 17:35:53 EDT
Created attachment 104552 [details]
/etc/yum.conf with only one mirror an enabling glibc*-updates
Comment 15 Seth Vidal 2004-09-29 17:39:00 EDT
just for fun:

uname -m


Comment 16 Bernhard Erdmann 2004-09-29 17:39:44 EDT
# uname -m
i686
Comment 17 Michael Schwendt 2004-09-29 17:44:00 EDT
Cannot reproduce. Same mirror, same package versions as in comment 6,
yum-2.1.3-1. Just upgraded glibc:

[...]
Dependencies Resolved
                [u] glibc.i686 0:2.3.3-59 - user
                [u] glibc-common.i386 0:2.3.3-59 - dep
Is this ok [y/N]: y
[...]
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
glibc-common 100 % done 1/4 
glibc 100 % done 2/4 
Completing update for glibc  - 3/4
Completing update for glibc-common  - 4/4
Complete!



Does "yum update glibc" work for Bernhard?
Comment 18 Bernhard Erdmann 2004-09-29 17:46:07 EDT
no, it does not work (glibc* is _not_ excluded by /etc/yum.conf):

# yum -y update glibc
Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB   
00:00 
Reading repository metadata in from local files
developmen: ################################################## 3441/3441
Excluding Packages in global exclude list
Finished
Could not find update match for glibc
No Packages marked for Update/Obsoletion
Comment 19 Bill Nottingham 2004-09-29 17:46:58 EDT
Out of curiousity...

what happens if you do 'rm -f /var/cache/yum/development/*xml*'?
Comment 20 Bernhard Erdmann 2004-09-29 17:56:00 EDT
using only the wftp.tu-chemnitz.de-mirror, because
download.fedora.redhat.com is very slow at the moment:

# rm -f /var/cache/yum/development/*xml*
# yum -y update
Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB   
00:00 
Reading repository metadata in from local files
primary.xml.gz              6% |=                        |  64 kB   
00:04 ETAprimary.xml.gz             13% |===                      |
128 kB    00:03 ETAprimary.xml.gz             20% |=====             
      | 192 kB    00:03 ETAprimary.xml.gz             27% |======    
              | 256 kB    00:03 ETAprimary.xml.gz             34%
|========                 | 320 kB    00:03 ETAprimary.xml.gz        
    41% |==========               | 384 kB    00:02 ETAprimary.xml.gz
            47% |===========              | 448 kB    00:02
ETAprimary.xml.gz             54% |=============            | 512 kB 
  00:02 ETAprimary.xml.gz             61% |===============          |
576 kB    00:01 ETAprimary.xml.gz             68% |================= 
      | 640 kB    00:01 ETAprimary.xml.gz             75%
|==================       | 704 kB    00:01 ETAprimary.xml.gz        
    82% |====================     | 768 kB    00:00 ETAprimary.xml.gz
            89% |======================   | 832 kB    00:00
ETAprimary.xml.gz             95% |=======================  | 896 kB 
  00:00 ETAprimary.xml.gz            100% |=========================|
934 kB    00:04 
developmen: ################################################## 3441/3441
Excluding Packages in global exclude list
Finished
Resolving Dependencies
Processing Dependency: glibc-common= 2.3.3-53 for package: glibc
Finished Dependency Resolution
Error: missing dep: glibc-common for pkg glibc
Comment 21 Seth Vidal 2004-09-30 01:14:26 EDT
okay
yum -d 5 update >> somefile

attach that file to this bug.
Comment 22 Bernhard Erdmann 2004-09-30 06:17:44 EDT
Created attachment 104574 [details]
yum debug file

yum -d 5 update >> yum.debug.log 2>&1
Comment 23 Seth Vidal 2004-09-30 08:18:41 EDT
Go into /var/cache/yum/ and remove all .xml.gz and .xml files from any
subdir, please.


Comment 24 Bernhard Erdmann 2004-09-30 09:08:41 EDT
Created attachment 104582 [details]
yum debug log after deleting /var/cache/yum/*

rm -rf /var/cache/yum/*
yum -d 5 update > yum.debug.log 2>&1
Comment 25 Bernhard Erdmann 2004-10-03 10:28:37 EDT
I guess yum does not recognize the glibc.i686 package on the mirror
and refuses to install the glibc.i386 package.

# yum -y list glibc
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3422/3422
Excluding Packages in global exclude list
Finished
Installed Packages
glibc.i686 2.3.3-53                                                 
installed 
Available Packages
glibc.i386 2.3.3-63                                                 
development

# yum -y update
Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3422/3422
Excluding Packages in global exclude list
Finished
Resolving Dependencies
Processing Dependency: glibc-common= 2.3.3-53 for package: glibc
Finished Dependency Resolution
Error: missing dep: glibc-common for pkg glibc

In the meanwhile, yum has been updates to yum-2.1.4-1.

The glibc.i686 is available on the mirror:
http://wftp.tu-chemnitz.de/pub/linux/fedora-core/development/i386/Fedora/RPMS/glibc-2.3.3-63.i686.rpm

# yum -y list glibc.i686
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3422/3422
Excluding Packages in global exclude list
Finished
Installed Packages
glibc.i686 2.3.3-53                                                 
installed 
Comment 26 Bernhard Erdmann 2004-10-07 15:03:00 EDT
I solved it. yum thought is was on i586 and refused to update the
glibc.i686 package.

The box was installed with Fedore Core 2 when it was on an AMD K6/400
CPU. Then it was upgraded first to a P4 CPU and afterwards to Fedora
Core 3 test 2.

yum takes /etc/rpm/platform for deciding whether to install i386, i586
oder i686 binary RPMs.

The installation of FC2 wrote "i586-redhat-linux" into
/etc/rpm/platform when it was running an AMD K6 CPU. This was not
adjusted by the upgrade to FC3t2 when it was running a P4 CPU but the
glibc.i686 was installed by the upgrade. Later, yum refused to upgrade
glibc because it still felt running on i586.

After correcting /etc/rpm/platform to "i686-redhat-linux", the problem
went away.


--> yum list with /etc/rpm/platform = "i586-redhat-linux":
# yum list glibc
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3423/3423
Installed Packages
glibc.i686 2.3.3-53                                                 
installed
Available Packages
glibc.i386 2.3.3-66                                                 
development


--> yum list with /etc/rpm/platform = "i686-redhat-linux":
# yum list glibc
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3423/3423
Installed Packages
glibc.i686 2.3.3-53                                                 
installed
Available Packages
glibc.i686 2.3.3-66                                                 
development
glibc.i386 2.3.3-66                                                 
development

Note You need to log in before you can comment on or make changes to this bug.