Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1337099 - Tech preview release contains GA string in os-release
Summary: Tech preview release contains GA string in os-release
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-release-rhev-hypervisor
Version: 3.6.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.0.0-beta
: 4.0.0
Assignee: Fabian Deutsch
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-18 09:48 UTC by cshao
Modified: 2016-08-23 21:12 UTC (History)
9 users (show)

Fixed In Version: redhat-release-rhev-hypervisor-3.6-0.26.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 21:12:11 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
all log info (5.86 MB, application/x-gzip)
2016-05-18 09:52 UTC, cshao
no flags Details
ngm.ks (162 bytes, text/plain)
2016-05-18 10:14 UTC, cshao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1688 0 normal SHIPPED_LIVE redhat-release-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:37:04 UTC

Description cshao 2016-05-18 09:48:08 UTC
Description of problem:
Incorrect info in /etc/system-release-cpe, should remove "ga" info from this file.

# cat /etc/system-release-cpe 
cpe:/o:redhat:enterprise_linux:7.2:ga:hypervisor


Version-Release number of selected component (if applicable):
rhev-hypervisor7-ng-3.6-20160516.0
rhev-hypervisor7-ng-image-update-3.6-20160516.0.el7.noarch.rpm
imgbased-0.6-0.1.el7ev.noarch


How reproducible:
100%

Steps to Reproduce:
1. Install NGN
2. Login NGN and run command #cat /etc/system-release-cpe 
3.

Actual results:
Incorrect info in /etc/system-release-cpe.

Expected results:
Should remove "ga" info from /etc/system-release-cpe.

Additional info:

Comment 1 cshao 2016-05-18 09:52:32 UTC
Created attachment 1158697 [details]
all log info

This bug only occurs on d/s.

Comment 2 cshao 2016-05-18 10:14:30 UTC
Created attachment 1158698 [details]
ngm.ks

Comment 5 cshao 2016-06-02 03:37:17 UTC
Test version:
rhev-hypervisor7-ng-3.6-20160518.0.x86_64
redhat-release-rhev-hypervisor-3.6-0.27.el7.x86_64
imgbased-0.6-0.1.el7ev.noarch

# cat /etc/system-release-cpe 
cpe:/o:redhat:enterprise_linux:7.2:beta:hypervisorng

Test result:
The GA string in os-release has been removed, so the bug is fixed, change bug status to VERIFIED.

Comment 7 errata-xmlrpc 2016-08-23 21:12:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1688.html


Note You need to log in before you can comment on or make changes to this bug.