Bug 133735 - HTTP install, fails to resolve hostname
Summary: HTTP install, fails to resolve hostname
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-27 01:28 UTC by Warren Togami
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 20:14:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Warren Togami 2004-09-27 01:28:39 UTC
Description of problem:
My home DNS server resolves 'wombat' as 172.31.16.2.  That worked when
I chose HTTP install and entered the hostname as 'wombat'.  But when
it gets to the point where it wanted to download hdlist, it failed
because it is no longer able to resolve 'wombat'.

/etc/resolv.conf was still pointing at my home DNS server, and ALT-F2
reveals that it is able to lookup regular names like 'www.google.com'.
 Somehow it is not able to lookup local names?

In any case, it worked after I manually added the entry to /etc/hosts.

Version-Release number of selected component (if applicable):
FC3-test2 i386

Comment 1 Jeremy Katz 2004-09-27 18:21:44 UTC
So ping wombat from tty2 doesn't work?

Comment 2 Warren Togami 2004-09-28 07:43:49 UTC
Yes, does not work from tty2.  Is there anything different about the
resolver here than when I began the HTTP install?

Comment 3 Jeremy Katz 2004-09-28 14:13:50 UTC
There shouldn't be.  And /etc/resolv.conf is still correct?

Comment 4 Warren Togami 2004-09-28 20:08:09 UTC
Yes, and I am able to reproduce this easily.


Comment 5 Jeremy Katz 2004-09-28 21:07:52 UTC
Did it work in the past?  Jakub -- any ideas?

Comment 6 Warren Togami 2004-09-28 22:15:38 UTC
I haven't had local lan domain names before, so I don't know.


Comment 7 Warren Togami 2004-10-22 02:58:39 UTC
Still fails to resolve in FC3-3.1.

Comment 8 Warren Togami 2005-03-29 08:10:03 UTC
New thought... is there any difference here where it does only forward resolve
in one place, and forward+reverse resolve in another?

Comment 9 Jeremy Katz 2005-04-27 23:10:31 UTC
Nothing I can think of.  Is this still broken?

Comment 10 Warren Togami 2005-04-28 02:28:36 UTC
Last tested in FC4test1 yes.


Comment 11 Jeremy Katz 2005-09-21 20:52:20 UTC
Was it the case in FC4 final?

Comment 12 Jeremy Katz 2006-04-26 20:14:45 UTC
Closing due to inactivity.


Note You need to log in before you can comment on or make changes to this bug.