Bug 133766 - Anaconda unmount is not clean
Summary: Anaconda unmount is not clean
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-27 11:32 UTC by Alan Cox
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 12:44:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2004-09-27 11:32:45 UTC
Upgrading a dual PIV box with an md mirrored root file system and md0
swap I got the strange error
Unable to unmount /dev/sda3\040

at end time. When I reboot after the upgrade the ext3fs is dirty and a
recovery is performed.

Comment 1 Jeremy Katz 2004-09-27 18:28:20 UTC
That's ... odd.  Where do you get it?  And what is sda3?

Comment 2 Alan Cox 2004-09-27 20:16:48 UTC
It turned up at the end of the upgrade after the upgrade went fine.

/dev/sda3 is the swap partition. I don't see any odd characters in
/etc/fstab 


Comment 3 Jeremy Katz 2004-09-28 01:46:58 UTC
If you start an upgrade (and don't finish it, just get to where it
finds packages to upgrade), can you switch to tty2 and see what
/proc/swaps has in it?

What other messages were around the "Unable to umount /dev/sda3" message?

Comment 4 Alan Cox 2004-09-28 16:18:50 UTC
The messages were the other unmounting ones followed by a reboot as
expected at the end of install.

The /proc file contains 
/dev/sda3    partition .. etc

I've used od and there is no \040 in it at all.


Comment 5 Jeremy Katz 2005-02-02 02:54:39 UTC
Did this still happen wiht FC3 final?

Comment 6 Alan Cox 2005-02-02 08:36:22 UTC
I've not seen it since the beta



Note You need to log in before you can comment on or make changes to this bug.