Bug 133789 - start_udev errors on read-only filesystem
Summary: start_udev errors on read-only filesystem
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-27 14:05 UTC by Thomas Zehetbauer
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: udev-032-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 09:54:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Zehetbauer 2004-09-27 14:05:46 UTC
/sbin/start_udev is called before the root filesystem is checked and
remounted rw, this causes the following error messages:

Mounting... tmpfs at /dev/:  mount: wrong fs type, bad option, bad
superblock on none,
       or too many mounted file systems
Making extra nodes:  ln: creating symbolic link `/dev//fd' to
`/proc/self/fd': Read-only file system
ln: creating symbolic link `/dev//stdin' to `/proc/self/fd/0':
Read-only file system
ln: creating symbolic link `/dev//stdout' to `/proc/self/fd/1':
Read-only file system
ln: creating symbolic link `/dev//stderr' to `/proc/self/fd/2':
Read-only file system
ln: creating symbolic link `/dev//core' to `/proc/kcore': Read-only
file system
MAKEDEV: error making /dev/fd1: Read-only file system
ln: creating symbolic link `/dev/MAKEDEV' to `/sbin/MAKEDEV':
Read-only file system
                                                           [FAILED]
Starting udev:  rm: cannot remove `/dev//.udev.tdb': Read-only file system
                                                           [FAILED]

Comment 1 Harald Hoyer 2004-09-28 09:33:39 UTC
which version of udev?

Comment 2 Harald Hoyer 2004-09-28 09:50:22 UTC
selinux or not?

Comment 3 Harald Hoyer 2004-09-28 09:50:50 UTC
maybe a duplicate of bug 133465 which is already fixed

Comment 4 Reuben Farrelly 2004-09-28 12:34:16 UTC
I'm seeing the same messages also, with the bleeding edge of
fedora-devel, and not using selinux.  The Fedora kernels work ok but a
non-initrd kernel will give me these errors.  The duplicate bug says
it is fixed in rawhide, but gives no further details as to what was
wrong or in fact fixed.

Has a decision been made that only FC kernels or ones with initrd's
will work without breakage?


Comment 5 raxet 2004-09-28 13:01:36 UTC
I have the same more or less happening here:
Running latest dev updates for FC3T2 here. Last updated this am. 9-27-04

I get the following during kernel boot. Nothing in the logs, pre
-initscripts stuff:

ln: cannot remove '/dev/stdin' Read Only File System
ln: cannot remove '/dev/stdout' Read Only File System
ln: cannot remove '/dev/stderr' Read Only File System
ln: cannot remove '/dev/core' Read Only File System

Then I get this:

ln /dev/MAKEDEV /sbin/MAKEDEV rm: cannot remove /dev//.udev.tdb Read
Only File System

Then everything carries on without a glitch.



Comment 6 raxet 2004-09-28 13:03:47 UTC
Oh, forgot to state the versions and using selinux btw
udev-032-2 

Comment 7 Harald Hoyer 2004-09-28 13:44:19 UTC
does this http://people.redhat.com/~harald/udev-032-4.i386.rpm fix
your problem?

Comment 8 Thomas Zehetbauer 2004-09-28 15:48:39 UTC
udev-032-2.x86_64 with custom kernel and no initrd

How do I find out if selinux is enabled?

Comment 9 raxet 2004-09-29 04:21:13 UTC
Updating with udev-032-4 nets this result on reboot:

/sbin/start_udev

line 79: syntax error near unexpected token '}'
line 79: '}'

have fun :)

Comment 10 Harald Hoyer 2004-09-29 08:47:06 UTC
*oops*, sorry... release -5 on the way


Note You need to log in before you can comment on or make changes to this bug.