Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1338066 - aliasesdb[28165]: /usr/libexec/postfix/aliasesdb: line 13: /usr/bin/newaliases: No such file or directory
Summary: aliasesdb[28165]: /usr/libexec/postfix/aliasesdb: line 13: /usr/bin/newaliase...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: postfix
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-21 11:19 UTC by Vedran Miletić
Modified: 2016-06-17 09:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-17 09:59:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Vedran Miletić 2016-05-21 11:19:31 UTC
Restarting postfix results in

aliasesdb[28165]: /usr/libexec/postfix/aliasesdb: line 13: /usr/bin/newaliases: No such file or directory

There is only newaliases.postfix in /usr/bin

# ls -la /usr/bin/newaliases*
lrwxrwxrwx. 1 root root 31 May 16 18:04 /usr/bin/newaliases.postfix -> ../../usr/sbin/sendmail.postfix

Comment 1 Jaroslav Škarvada 2016-05-23 09:07:36 UTC
Maybe this is a dupe of older bug when esmtp took over in alternatives. In such case there is nothing to fix in postfix and AFAIK the esmtp has been already fixed.

Try:
# alternatives --config mta

and select postfix (or alternatively select sendmail and then postfix), this should fix the links.

Comment 2 Vedran Miletić 2016-06-16 22:29:59 UTC
Sorry for a late response. It did.

Comment 3 Jaroslav Škarvada 2016-06-17 09:59:51 UTC
(In reply to Vedran Miletić from comment #2)
> Sorry for a late response. It did.

Thanks for info. Older installation media cannot be fixed, but this should be fixed in current repo, so closing as current release. Feel free to reopen if you can come with reliable reproducer.


Note You need to log in before you can comment on or make changes to this bug.