Bug 133811 - apol crashes when closing latest version 18 source policy
Summary: apol crashes when closing latest version 18 source policy
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: setools   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-27 17:35 UTC by Don Patterson
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 23:04:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix bugs in setools (2.53 KB, patch)
2004-09-27 17:44 UTC, Don Patterson
no flags Details | Diff
Patch to fix critical bugs in libapol. (4.72 KB, patch)
2004-10-06 20:33 UTC, Don Patterson
no flags Details | Diff

Description Don Patterson 2004-09-27 17:35:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
Using Fedora development (Rawhide): 
open /etc/selinux/strict/src/policy/policy.conf  then immediately open
/etc/selinux/strict/policy/policy.18 and apol immediately crashes with
"*** glibc detected *** corrupted double-linked list:" and a hex 
number. 



Version-Release number of selected component (if applicable):
setools-1.4.1 and setools-gui-1.4.1

How reproducible:
Always

Steps to Reproduce:
1.start apol
2.Using Fedora development (Rawhide) apol running in targeted 
enforcing mode (although I doubt that matters) 
open /etc/selinux/strict/src/policy/policy.conf 
3.then immediately open /etc/selinux/strict/policy/policy.18 and 

apol immediately crashes with:
"*** glibc detected *** corrupted double-linked list:" and a hex 
number.    

Expected Results:  apol should have closed the policy successfully. 

Additional info:

Comment 1 Don Patterson 2004-09-27 17:44:46 UTC
Created attachment 104386 [details]
Patch to fix bugs in setools

This patch not only fixes the bug mentioned in this report but also:

1. a tcl bug in sepcut 
2. a bug in libapol when loading certaing rules from a binary policy.

Comment 2 Daniel Walsh 2004-09-28 11:18:58 UTC
setools-1.4.1-2 includes this patch.

Comment 3 Don Patterson 2004-10-06 20:33:35 UTC
Created attachment 104864 [details]
Patch to fix critical bugs in libapol.

Comment 4 Don Patterson 2004-10-06 20:35:20 UTC
Dan, this is an updated and thoroughly tested patch for the setools-
1.4.1 package. The previous patch is known to cause a problem with 
rendering allow rules in apol. Thanks.

Comment 5 Rahul Sundaram 2005-08-13 20:06:38 UTC

setting priority to high since patch is included. Has this been incorporated yet?

Comment 6 Daniel Walsh 2005-08-14 19:48:21 UTC
Incorporated in what?

This is fixed in Fedora Devel.  We are at version 2.1.1-2


Note You need to log in before you can comment on or make changes to this bug.