Bug 133833 - df returns value of "1" for "1-K", "Used", "Available" fields for NFS mounted reiserfs filesystems
df returns value of "1" for "1-K", "Used", "Available" fields for NFS mounte...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-27 16:01 EDT by Matthew Peterson
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:56:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of df on kernel-2.4.21-20.EL (has problems, returns value of 1 for df) (4.73 KB, text/plain)
2004-09-27 16:15 EDT, Matthew Peterson
no flags Details
strace of df on kernel-2.4.21-15.0.4.EL (does not have the problem with reiserfs) (4.73 KB, text/plain)
2004-09-27 16:16 EDT, Matthew Peterson
no flags Details

  None (edit)
Description Matthew Peterson 2004-09-27 16:01:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5 (KHTML, 
like Gecko) Safari/125.9

Description of problem:
'df' using kernel-2.4.21-20.EL (RedHat WS v3) reports values of "1" in the fields "1K-
blocks", "Used", "Available" for NFS mounted reiserfs systems.  

kernel-2.4.21-15.0.4.EL does not exhibit this problem.

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.EL


How reproducible:
Always

Steps to Reproduce:
1. On kernel-2.4.21-20.EL run:  strace /bin/df /disks/data/omm_vol7/.
    # omm_vol7 is a NFS mounted reiserfs filesystem, in this case, 460GB
2. Run df /disks/data/omm_vol7/

Actual Results:  
------------------
kernel-2.4.21-20.EL
------------------
strace /bin/df /disks/data/omm_vol7/. (specifically the statfs section):
-----
statfs("/disks/data/omm_vol7", {f_type="NFS_SUPER_MAGIC", f_bsize=4294967295, 
f_blocks=4294967295, f_bfree=4294967295, f_bavail=4294967295, 
f_files=4294967295, f_ffree=4294967295, f_fsid={0, 0}, f_namelen=255, f_frsize=0}) = 0
-----
Results of: df /disks/data/omm_vol7
-----
Filesystem           1K-blocks      Used Available Use% Mounted on
saffron:/data1/omm_vol7
                             1         1         1   0% /disks/data/omm_vol7


Expected Results:  
---------------------
kernel-2.4.21-15.0.4.EL
---------------------
strace /bin/df /disks/data/omm_vol7/. (specifically the statfs section):
-----
statfs("/disks/data/omm_vol7", {f_type="NFS_SUPER_MAGIC", f_bsize=4096, 
f_blocks=118485686, f_bfree=6162848, f_bavail=6162848, f_files=4294967295, 
f_ffree=4294967295, f_fsid={0, 0}, f_namelen=255, f_frsize=0}) = 0
-----
Results of: df /disks/data/omm_vol7
-----
Filesystem           1K-blocks      Used Available Use% Mounted on
saffron:/data1/omm_vol7
                     473942744 449291352  24651392  95% /disks/data/omm_vol7

Additional info:

In fixing #126657 "df wrong output terabyte", was this bug created?
Comment 1 Matthew Peterson 2004-09-27 16:15:50 EDT
Created attachment 104396 [details]
strace of df on kernel-2.4.21-20.EL (has problems, returns value of 1 for df)
Comment 2 Matthew Peterson 2004-09-27 16:16:50 EDT
Created attachment 104397 [details]
strace of df on kernel-2.4.21-15.0.4.EL (does not have the problem with reiserfs)
Comment 3 Matthew Peterson 2004-09-27 17:49:57 EDT
Just noticed that this is simliar to: 132525
Comment 4 Ernie Petrides 2004-09-27 21:51:10 EDT

*** This bug has been marked as a duplicate of 132244 ***
Comment 5 John Flanagan 2004-12-20 15:56:43 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.