Bug 133837 - RFE: Upstream version of tvtime: 0.9.13
RFE: Upstream version of tvtime: 0.9.13
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tvtime (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
http://cvs.sourceforge.net/viewcvs.py...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-27 16:21 EDT by Zuirdj
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 15:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuirdj 2004-09-27 16:21:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
Rawhide version is 0.9.12 (Fri Nov 21 23:29:32 AST 2003) + minor
enhancemets (0.9.12-10) . Version 0.9.13 was released on Sat Sep 25
13:51:13 EDT 2004 and fixes many bugs, including adding support for
PAL-DK users who use the cx88 driver.

Changelog:

- German translation of man pages.
- Added code to set the XMLTV language using the command
SET_XMLTV_LANGUAGE.
- Mute the mixer device on exit to work around noisy capture cards.
- Save mute state across tvtime sessions.
- Added code for toggling the XMLTV language using the command
TOGGLE_XMLTV_LANGUAGE.  Thanks to Ingo van Lil for the patch.
- Support toggling PAL- DK/PAL- BG audio mode as a global setting, and
added per- channel support for overriding this setting.  This should
solve problems for cx88 users where the driver cannot identify the
audio signal.
- Added an option for making screenshots "quiet", where they will not
announce themselves on the OSD.
- Added a compatibility layer for xawtv- remote and the corresponding
_XAWTV_REMOTE window property.
- Added support for the _XAWTV_STATION window property, which
announces which channel we are set to.
- Save always- on- top state across shutdown of tvtime.
- Replaced the OutputHeight configuration with window geometry support
using the - - geometry command line option.
- Removed the tvtime console, it was not really useful and confusing
users when it popped up.
- Removed support for configurable "modes", which were used for having
things like a special fullscreen mode with a different deinterlacer. 
The feature was too complicated to be usable and cluttered the code,
and not appropriate for our 1.0 release.
- Show the title of the current show from the XMLTV information in the
window title bar if available.
- Show the channel number in the window title bar if available.
- Added code for reading localized descriptions from the XMLTV file. 
Thanks to Ingo van Lil for the patch.
- Fixed an insanely bad race condition in the not- using- RTC code. 
This should solve some weird, inexplicable hangs.  Thanks to Roman
Glebov for his help debugging this.
- Add Dirk Ziegelmeier's gcc ports of the greedyh and tomsmocomp
deinterlacers.  Removed the now unnecessary wine loader code and the
DLLs from the build.
- Always keep the mixer device open to work around a weird problem
with the ALSA emulation where it only maintains volume state during an
open and not across sessions.
- Added a setting called 'audio boost' to control the volume we set on
the capture card itself.
- Return the magic number 3 when tvtime exits from a SLEEP command. 
Useful for writing scripts that do something after tvtime quits from
sleep mode.
- We now set the aspect ratio hints based on the matte setting.
- Fixed a nasty segfault when the capture card driver errors out on
the first few frames.
- We now always mute the sound card on channel change to protect
against all of the broken drivers.
- Removed MPEG2 support which did not work anyway.
- Removed SDL, MGA, and DirectFB output drivers, since they are
unmaintained and all have various problems.  Removed the command line
parameters for selecting an output driver as well.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.-
2.-
3.-
    

Additional info:
Comment 1 Ngo Than 2004-09-29 15:27:17 EDT
i have built tvtime-0.9.13 in fc3 tree. it will show up in rawhide soon

Note You need to log in before you can comment on or make changes to this bug.