Bug 133857 - USB not loaded
USB not loaded
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-27 18:25 EDT by Moritz Barsnick
Modified: 2014-03-16 22:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 12:29:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsmod with initscripts-7.50-1 (3.15 KB, text/plain)
2004-09-27 18:26 EDT, Moritz Barsnick
no flags Details

  None (edit)
Description Moritz Barsnick 2004-09-27 18:25:19 EDT
Description of problem:
The init scripts do not load the USB modules anymore.

Version-Release number of selected component (if applicable):
initscripts-7.82-1

How reproducible:
for me

Steps to Reproduce:
1. boot
2. lsmod | grep usb
3.
  
Actual results:
no usb modules

Expected results:
find usb modules

Additional info:
This is really boggling me. First off: All I can say is, it works 
with initscripts-7.50-1, it doesn't work with initscripts-7.82-1.

I had some recent (also peculiar) problems with my Ethernet 
controller not being automatically loaded (using 7.50-1), noticed 
some buglets in the init scripts, and decided to update after reading 
the changelog. With 7.82-1, my Ethernet driver was now automatically 
loaded, but the USB modules (and also /proc/bus/usb/ of course) 
disappeared. I do not know what to do to load them manually, at least 
not enough to get my USB modem to work (USB Flash drive works 
manually). Reverting to initscripts-7.50-1 gets everything 
operational again. The DSL modem is USB via hotplug (Allied Telesyn 
AT-AR215), but that's not the point. It can't initialize because it 
misses usb support at boot. Any ideas? Any log files I can help out 
with?

If I had some of the intermediate initscripts versions available, I 
could check which version breaks my USB. Perhaps someone can provide 
me these.

I'm running FC2 + some of FC devel, kernel 2.4.22-1.2188+some 
modifications (2.4 because of said USB DSL driver, which I haven't 
got to work out of the box with 2.6 yet), no udev (as far as I can 
tell ;-> the package is there, but I see no proof of it running), and 
said USB driver is eagle-usb-de, http://atar215-linux.sf.net/ .

Thanks for any help!
Comment 1 Moritz Barsnick 2004-09-27 18:26:53 EDT
Created attachment 104405 [details]
lsmod with initscripts-7.50-1
Comment 2 Bill Nottingham 2004-09-28 12:29:42 EDT
Current initscripts do not work with 2.4 kernels.

Note You need to log in before you can comment on or make changes to this bug.