Bug 133863 - Fails to boot from USB device
Fails to boot from USB device
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-27 19:24 EDT by Randall Wood
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 21:39:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randall Wood 2004-09-27 19:24:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
When GRUB is on a USB device and is attempting to boot, it hangs with 
this message:

Attempting Boot From USB Device
GRUB _

(the underscore is where the cursor sits)

Attempted fix:
boot from rescue cd
mount /dev/sda1 /mnt/sysimage/boot
chroot /mnt/sysimage
mkinitrd -v --with-usb /boot/initrd-usb-2.6.8-1.154.img 2.6.8-1.154
exit
exit
<reboots>

and it still hangs at the same point


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Boot from USB Device

Actual Results:  System hangs during boot

Expected Results:  System boots into Fedora Linux

Additional info:
Comment 1 Randall Wood 2004-09-27 20:45:02 EDT
Reinstalled Fedora fc3test2, with GRUB in the MBR on the USB drive 
instead of first block of /dev/sda1 (the installer was unclear about 
the advantage of this change)
Reboot, and grub loads vmlinux, but the kernel panics.

Attempted fix:
boot from rescue cd
mount /dev/sda1 /mnt/sysimage/boot
chroot /mnt/sysimage
mkinitrd -v --with-usb /boot/initrd-usb-2.6.8-1.154.img 2.6.8-1.154
edit /boot/grub/grub.conf to use new initrd
exit
exit
<reboot>

kernel panics again
here is a hand copy of the kernel output:

audit(1096317010.4294965466:0): initialized
hdd: No disk in drive
Red Hat nash version 4.1.11 starting
  Reading all physical volumes.  This may take a while...
ide-floppy: hdd: I/O error, pc =  0, key =  2, asc = 3a, ascq =  0
ide-floppy: hdd: I/O error, pc = 1b, key =  2, asc = 3a, ascq =  0
hdd: No disk in drive
  No volume groups found
  No volume groups found
  No volume groups found
mount: error 2 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!
 _
(the _ marks the cursor location)
Comment 2 Jeremy Katz 2004-09-27 21:39:36 EDT
Installs to USB hard drives aren't supported because of these sorts of
reasons.

Note You need to log in before you can comment on or make changes to this bug.