Bug 133865 - error messages with HP 6300C scanner on USB
Summary: error messages with HP 6300C scanner on USB
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-27 23:34 UTC by Thomas Zehetbauer
Modified: 2013-03-06 03:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 10:04:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Zehetbauer 2004-09-27 23:34:54 UTC
Starting cups with HP 6300C scanner connected on USB causes the kernel
error message "usb 2-3: control timeout on ep0in" to be printed 5
times with about 5 seconds delay each.

Sep 28 01:36:24 hostmaster cups: cupsd shutdown succeeded
Sep 28 01:36:24 hostmaster kernel: hal[24383]: segfault at
0000000000000000 rip 0000000000400ec7 rsp 0000007fbfffd400 error 4
Sep 28 01:36:29 hostmaster kernel: usb 2-3: control timeout on ep0in
Sep 28 01:36:44 hostmaster last message repeated 3 times
Sep 28 01:36:45 hostmaster cups: cupsd startup succeeded

Comment 1 Thomas Zehetbauer 2004-09-27 23:45:54 UTC
I forgot to mention the relevant package versions: cups-1.1.21-2,
kernel-2.6.8.1, hal-0.2.98.cvs20040923-1

Comment 2 Warren Togami 2004-09-28 07:41:31 UTC
Comment #1 indicates that you are not using a Fedora kernel.

Comment 3 Thomas Zehetbauer 2004-09-28 23:18:04 UTC
Warren: According to Alan Cox there is no general rule to discard bug
reports from users of non Fedora supplied kernels. Additionlly this
bug can be reproduced with kernel-2.6.8-1.541.x86_64

Tim: Alan thinks this is a bug in hal, as it is triggered by cups I
initially attributed it to cups

Comment 4 David Zeuthen 2004-09-29 07:15:25 UTC
I would be surprised if this was a bug in hal as we doesn't do
anything for scanners. Does stopping the hal daemon, 'service
haldaemon stop', stop this continual logging?

Please try 'service haldaemon stop', and run 'hald --verbose=yes
--daemon=no' and attach the output to this bug report. IF this
succeeds please also attach the output of 'lshal'.

Thanks,
David

Comment 5 Thomas Zehetbauer 2004-09-29 10:04:20 UTC
I have just traced this down to be a kernel problem, the error message
occurs whenever reading /proc/bus/usb/devices, cups' canon driver does
this on startup, hald every few seconds, I have filed a kernel bug:
http://bugzilla.kernel.org/show_bug.cgi?id=3489

Comment 6 David Zeuthen 2004-09-29 14:03:05 UTC
Thomas, thanks for figuring this out. In fact, I plan to change hal to
not read the /proc/bus/usb/devices file since all that information is
also in sysfs as of 2.6.6.


Note You need to log in before you can comment on or make changes to this bug.