Bug 133868 - upgrade from fc2 w/ modified yum.conf to fc3t2 leaves yum unusable
upgrade from fc2 w/ modified yum.conf to fc3t2 leaves yum unusable
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-27 21:02 EDT by Matthew Nuzum
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 23:54:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Nuzum 2004-09-27 21:02:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040904 Firefox/0.9.3

Description of problem:
Upgraded to fc3t2 from fc2. Some time ago I had modified my fc2
yum.conf to point to some mirrors. I used the yum.conf from fedorafaq.

After install finished and I booted into the os the rhn applet showed
many updates.  I tried to use up2date but it's incredibly slow.
Decided to revert to yum.

Yum gave several 404 errors.  I noticed that in the /etc folder there
was a yum.conf.rpmnew file, so I replaced my modified yum.conf file
with the rpmnew version and everything worked perfectly.

Maybe this isn't a bug, or maybe it is but it won't be an issue when
things go live and mirrors get copies of the fc3 final.

Version-Release number of selected component (if applicable):
yum-2.1.3-1

How reproducible:
Always

Steps to Reproduce:
1. modify the yum.conf file on a working fc2 system using the yum.conf
file from fedorafaq (http://www.fedorafaq.org/samples/yum.conf)
2. upgrade to fc2t2
3. try to do a yum --update command. 
    

Actual Results:  404 errors

Expected Results:  Should have had an updated system

Additional info:

Fix this problem by replacing your modified /etc/yum.conf with
/etc/yum.conf.rpmnew
Comment 1 Bill Nottingham 2004-09-28 23:54:18 EDT
Well, you don't want to change a modified yum.conf in general, so I
believe this is behaving more or less as expected.

Note You need to log in before you can comment on or make changes to this bug.