Bug 133878 - while saving file name replace directory name
while saving file name replace directory name
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 04:16 EDT by Patrice Dumas
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 09:22:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2004-09-28 04:16:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040926
Firefox/0.10

Description of problem:
I open an already existing file in .doc format from the recently used
files. The file is in /home/sev/revue_detude/fiche_guide, named
croissance.doc.

After some editing I want to save my document in word .doc format. I
use the "save as" entry in the file menu, I get the (new) file
selector. If I don't change anything, and hit the "save" button, the
directory name is replaced by the file name. If I hit the "save"
button again, ooo gives an error message saying I/O error when saving
/home/sev/revue_detude/fiche_guide/croissance.doc/croissance.doc

If I change something in the file selector (change the file location,
reselect the type of document), everything is fine.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-5

How reproducible:
Always

Steps to Reproduce:
1. save as
2. hit save button twice
3.
    

Actual Results:  error message saying I/O error when saving the file
with file name appended to directory name

Expected Results:  file name not appended to the directory

Additional info:
Comment 1 Caolan McNamara 2004-09-29 03:47:16 EDT
Strange, I created a dir structure like yours, opened the doc, closed
it, selected it from the recent-files as you describe, when I make an
edit and use save->as and in the new dialog press save I progress
directly to "the file already exists. Overwrite ?", as expected. So
not something where the dialog changes to a dir with a name
croissance.doc.

If you can reproduce this at will, can you try using the "stock
dialog" by navigating
tools->options->OpenOffice.org->General->Open/Save Dialogs and select
"Use OpenOffice.org dialogs" and repeat your above procedure with the
old dialog. Is there a difference between new and old then ? I'm using
openoffice.org-1.1.2-6 for reference
Comment 2 Patrice Dumas 2004-09-29 05:52:34 EDT
First of all I tried with the old dialog and there is no such bug.

I have more informations. It seems that this bug is somehow linked
with the feature of remembering of the typed text in the file
selection. When I have already typed the text in the file name field
it appears in a field just below the text field. If the widget don't
remember the typed text, there is no bug.

It also seems that if there is some part of the text in the field
selected then the bug doesn't happen. For example if the file is in
the same directory as the one openoffice started in, the .doc part of
the file name may be already selected. In that case I have to click on
the text field to deselect it, otherwise the bug don't show.
Comment 3 Patrice Dumas 2004-09-29 07:23:58 EDT
Still the same issue with 1.1.2-6.
Comment 4 Caolan McNamara 2004-09-29 07:59:33 EDT
what is the output of "rpm -q gtk2" mine is gtk2-2.4.10-5. I've been
informed that something like that was seen in gaim's save as in the past.
Comment 5 Patrice Dumas 2004-09-29 08:48:40 EDT
I had gtk2-2.4.7-1, I have updated to gtk2-2.4.10-4 now there is no
bug anymore. The bug should be closed.
Comment 6 Caolan McNamara 2004-09-29 09:22:50 EDT
Excellent :-), good to get that figured out. 

Note You need to log in before you can comment on or make changes to this bug.