Bug 133883 - shadow utils man pages are in non-UTF-8 format
Summary: shadow utils man pages are in non-UTF-8 format
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: shadow-utils   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 132991
TreeView+ depends on / blocked
 
Reported: 2004-09-28 10:03 UTC by Bastien Nocera
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: 2:4.0.3-33
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 03:25:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
shadow-utils.spec.utf8manpages.patch (994 bytes, patch)
2004-09-28 10:04 UTC, Bastien Nocera
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:164 normal SHIPPED_LIVE shadow-utils bug fix update 2005-05-19 04:00:00 UTC

Description Bastien Nocera 2004-09-28 10:03:03 UTC
Version-Release number of selected component (if applicable):
4.0.3-20.05

Steps to Reproduce:
[root@atl1g:/]# export LANG=fr_FR.UTF-8
[root@atl1g:/]# man useradd
<standard input>:36: warning: can't find special character `u9972'
<standard input>:36: warning: can't find special character `u082A'
<standard input>:36: warning: can't find special character `u99A1'
<standard input>:45: warning: can't find special character `u9C1F'
<standard input>:76: warning: can't find special character `u9726'
[...]
<standard input>:136: warning: can't find special character `u024E'
<standard input>:141: warning: can't find special character `u98F5'
<standard input>:163: warning: can't find special character `u9929' 

An example spec file change attached below.

Comment 1 Bastien Nocera 2004-09-28 10:04:39 UTC
Created attachment 104422 [details]
shadow-utils.spec.utf8manpages.patch

Patch from Pancrazio 'Ezio' De Mauro <pdemauro@redhat.com>

Comment 2 Bastien Nocera 2004-10-13 16:05:11 UTC
RHEL3 bug, not Fedora Core.

Comment 3 Eido Inoue 2004-10-13 18:44:05 UTC
It's also built into U5

Comment 4 Petr Šimon 2005-03-31 06:18:11 UTC
It should be pointed out, that Japanese man pages will stay in eucjp, because
that's the default encoding for Japanese on RHEL3 systems.

Comment 5 Dennis Gregorovic 2005-05-20 03:25:51 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-164.html



Note You need to log in before you can comment on or make changes to this bug.