Bug 1338958 - Installing of a package ntp results in a dependecy problem on RHEL7.3-Server 20160520 build
Summary: Installing of a package ntp results in a dependecy problem on RHEL7.3-Server ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ntp
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miroslav Lichvar
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-23 17:54 UTC by Jan Stavel
Modified: 2016-05-24 14:53 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-24 14:53:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Stavel 2016-05-23 17:54:30 UTC
Description of problem:

   I have installed RHEL7.3 Server with GUI using my local virt-manager.
   Repo path: http://download.eng.brq.redhat.com/nightly/RHEL-7.3-20160520.n.0/compose/Server/x86_64/os/

   I wanted to install ntp package. It failed with dependency error.

Version-Release number of selected component (if applicable):


   Red Hat Enterprise Linux Server release 7.3 Beta (Maipo)
   ----------------------------     ----------------------------
   arch                             x86_64
   kernel version                   3.10.0-406.el7.x86_64
   ----------------------------     ----------------------------
   server type                      Red Hat Subscription Management
   subscription management server   0.9.51.15-1
   subscription management rules    5.15.1
   subscription-manager             1.17.6-1.el7
   python-rhsm                      1.17.2-1.el7
   ----------------------------     ----------------------------
   Product                          69.pem
   ----------------------------     ----------------------------
   Entitlement                      2204852377988864576.pem
   ----------------------------     ----------------------------


Steps to Reproduce:

*** I have registered using subcription-manager
*** I have attached a product
*** I was going to install ntp

    #+BEGIN_SRC shell
    yum install -y ntp  2>&1
    exit 0
    #+END_SRC

    #+RESULTS:
    #+begin_example
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    Resolving Dependencies
    --> Running transaction check
    ---> Package ntp.x86_64 0:4.2.6p5-22.el7_2.1 will be installed
    --> Processing Dependency: ntpdate = 4.2.6p5-22.el7_2.1 for package: ntp-4.2.6p5-22.el7_2.1.x86_64
    --> Finished Dependency Resolution
    Error: Package: ntp-4.2.6p5-22.el7_2.1.x86_64 (rhel-7-server-rpms)
               Requires: ntpdate = 4.2.6p5-22.el7_2.1
               Installed: ntpdate-4.2.6p5-25.el7.x86_64 (@anaconda/7.3)
                   ntpdate = 4.2.6p5-25.el7
               Available: ntpdate-4.2.6p5-18.el7.x86_64 (rhel-7-server-rpms)
                   ntpdate = 4.2.6p5-18.el7
               Available: ntpdate-4.2.6p5-19.el7_0.x86_64 (rhel-7-server-rpms)
                   ntpdate = 4.2.6p5-19.el7_0
               Available: ntpdate-4.2.6p5-19.el7_1.1.x86_64 (rhel-7-server-rpms)
                   ntpdate = 4.2.6p5-19.el7_1.1
               Available: ntpdate-4.2.6p5-19.el7_1.3.x86_64 (rhel-7-server-rpms)
                   ntpdate = 4.2.6p5-19.el7_1.3
               Available: ntpdate-4.2.6p5-22.el7.x86_64 (rhel-7-server-rpms)
                   ntpdate = 4.2.6p5-22.el7
               Available: ntpdate-4.2.6p5-22.el7_2.1.x86_64 (rhel-7-server-rpms)
                   ntpdate = 4.2.6p5-22.el7_2.1
    **********************************************************************
    yum can be configured to try to resolve such errors by temporarily enabling
    disabled repos and searching for missing dependencies.
    To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
    **********************************************************************

    Error: Package: ntp-4.2.6p5-22.el7_2.1.x86_64 (rhel-7-server-rpms)
               Requires: ntpdate = 4.2.6p5-22.el7_2.1
               Installed: ntpdate-4.2.6p5-25.el7.x86_64 (@anaconda/7.3)
                   ntpdate = 4.2.6p5-25.el7
               Available: ntpdate-4.2.6p5-18.el7.x86_64 (rhel-7-server-rpms)
                   ntpdate = 4.2.6p5-18.el7
               Available: ntpdate-4.2.6p5-19.el7_0.x86_64 (rhel-7-server-rpms)
                   ntpdate = 4.2.6p5-19.el7_0
               Available: ntpdate-4.2.6p5-19.el7_1.1.x86_64 (rhel-7-server-rpms)
                   ntpdate = 4.2.6p5-19.el7_1.1
               Available: ntpdate-4.2.6p5-19.el7_1.3.x86_64 (rhel-7-server-rpms)
                   ntpdate = 4.2.6p5-19.el7_1.3
               Available: ntpdate-4.2.6p5-22.el7.x86_64 (rhel-7-server-rpms)
                   ntpdate = 4.2.6p5-22.el7
               Available: ntpdate-4.2.6p5-22.el7_2.1.x86_64 (rhel-7-server-rpms)
                   ntpdate = 4.2.6p5-22.el7_2.1
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
#+end_example




Actual results:

There is some unresolved dependeny in a fresh RHEL7.3 installation.

Comment 2 Miroslav Lichvar 2016-05-24 06:05:57 UTC
It looks like ntpdate was already installed in the latest RHEL7.3 version (4.2.6p5-25.el7.x86_64), but corresponding ntp package is missing. It should be in the RHEL-7.3-20160520.n.0 compose. Is that repo enabled?

Comment 3 Jan Stavel 2016-05-24 12:16:29 UTC
Hi Miroslav. Thanks for an answer.

I suspect that I mixed repos from different compose tree wrong way.

I will try to reproduce this bug against and I will pay attention what repos are used.

I will send you a report.

Regars,
Jan

Comment 4 Jan Stavel 2016-05-24 14:53:53 UTC
Hi Miroslav
the bug was caused in such way that I have installed VM from night build compose.
After that I have subscribed a system using subscription-manager.
It added older repo and this bug was happen.

Once I enabled the proper repo this bug disappeared.

This is not a bug.

Regards,
Jan


Note You need to log in before you can comment on or make changes to this bug.