Bug 133949 - cman_tool leave: reporting number of active subsystems differently than /proc/cluster/services
cman_tool leave: reporting number of active subsystems differently than /proc...
Status: CLOSED NOTABUG
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christine Caulfield
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 12:47 EDT by Derek Anderson
Modified: 2010-01-11 21:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 03:07:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Derek Anderson 2004-09-28 12:47:23 EDT
Description of problem:  Running "cman_tool leave" with active
subsystems is reporting a different number than you get from cat-ting
/proc/cluster/services.  If I had to guess from the following output I
would say that "DLM Lock Space"s are counted twice.

[root@link-12 /]# cman_tool join
[root@link-12 /]# fence_tool join
[root@link-12 /]# cat /proc/cluster/services
Service          Name                              GID LID State     Code
Fence Domain:    "default"                           5   2 run       -
[1 3 2]

[root@link-12 /]# cman_tool leave
cman_tool: Can't leave cluster while there are 1 active subsystems

[root@link-12 /]# clvmd
[root@link-12 /]# cat /proc/cluster/services
Service          Name                              GID LID State     Code
Fence Domain:    "default"                           5   2 run       -
[1 3 2]

DLM Lock Space:  "clvmd"                             6   3 run       -
[1 3 2]

[root@link-12 /]# cman_tool leave
cman_tool: Can't leave cluster while there are 3 active subsystems

[root@link-12 /]# mount -t gfs /dev/FOO/lvol0 /data1
[root@link-12 /]# cat /proc/cluster/services
Service          Name                              GID LID State     Code
Fence Domain:    "default"                           5   2 run       -
[1 3 2]

DLM Lock Space:  "clvmd"                             6   3 run       -
[1 3 2]

DLM Lock Space:  "data1"                             7   4 run       -
[2]

GFS Mount Group: "data1"                             8   5 run       -
[2]

[root@link-12 /]# cman_tool leave
cman_tool: Can't leave cluster while there are 6 active subsystems

Version-Release number of selected component (if applicable):
[root@link-12 /]# cman_tool -V
cman_tool DEVEL.1096386823 (built Sep 28 2004 10:54:53)
Copyright (C) Red Hat, Inc.  2004  All rights reserved.


How reproducible:
Always.

Steps to Reproduce:
1. Join fence domain.  cman_tool leave reports 1 subsystem.
2. Start clvmd.  cman_tool leave reports 3 subsystems.
3. Mount GFS. cman_tool leave reports 6 subsystems.
  
Actual results:


Expected results:


Additional info:
Comment 1 Christine Caulfield 2004-09-29 03:07:06 EDT
I understand the confusion but it's not a bug. Read the messages
carefully and you will see that cman_tool refers to "subsystems" and
/proc/cluster/services refers to "services".

A "service" is something that interacts with the service manager and
will appear in /proc/cluster/services. A "subsystem" is a superset of
services and includes anything that has a connection to cman directly
(which clvmd does, hence the jump from 1 to 3 when it is started - it
has a lockspace and a direct connection).

If you have any suggestions as to reducing the confusion I'll happily
listen to them, but we already use two different words...
Comment 2 Kiersten (Kerri) Anderson 2004-11-16 14:07:47 EST
Updating version to the right level in the defects.  Sorry for the storm.

Note You need to log in before you can comment on or make changes to this bug.