This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 133954 - [PATCH] Make ThinkPad T42s PCMCIA always work
[PATCH] Make ThinkPad T42s PCMCIA always work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 13:06 EDT by Dax Kelson
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 19:14:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to add proper PCMCIA support for Thinkpad T42s (1.01 KB, patch)
2004-09-28 13:09 EDT, Dax Kelson
no flags Details | Diff

  None (edit)
Description Dax Kelson 2004-09-28 13:06:25 EDT
Description of problem:

In May of 2004, IBM released the new "42 and 42p" models of their very
popular T line. Some (maybe just the ones with 1.8 and 2.0 Ghz CPUs)
or all of the T42s have a new Cardbus bridge that isn't properly
recongized by yenta. The problem is that card inserts are not detected.

The odd thing is that without the following patch, card inserts will
be detected as long as another network interface (such as the onboard
NIC) is up.

With the patch everything is golden, and card inserts are always detected.

The patch is a 2 liner, presumably Russell King has it in his queue,
but who knows when it will makes it into the Linus kernel, and it
might not happen until after FC3 is released.

Please add to the rawhide kernel so that users of T42s everywhere will
have 100% working PCMCIA with FC3.

===== drivers/pcmcia/yenta_socket.c 1.59 vs edited =====
--- 1.59/drivers/pcmcia/yenta_socket.c  2004-08-22 15:39:15 +01:00
+++ edited/drivers/pcmcia/yenta_socket.c        2004-09-27 23:03:57 +01:00
@@ -1091,6 +1091,7 @@
        CB_ID(PCI_VENDOR_ID_TI, PCI_DEVICE_ID_TI_4410, TI12XX),
        CB_ID(PCI_VENDOR_ID_TI, PCI_DEVICE_ID_TI_4450, TI12XX),
        CB_ID(PCI_VENDOR_ID_TI, PCI_DEVICE_ID_TI_4451, TI12XX),
+       CB_ID(PCI_VENDOR_ID_TI, PCI_DEVICE_ID_TI_4520, TI12XX),
 
        CB_ID(PCI_VENDOR_ID_TI, PCI_DEVICE_ID_TI_1250, TI1250),
        CB_ID(PCI_VENDOR_ID_TI, PCI_DEVICE_ID_TI_1410, TI1250),
===== include/linux/pci_ids.h 1.176 vs edited =====
--- 1.176/include/linux/pci_ids.h       2004-08-28 19:46:04 +01:00
+++ edited/include/linux/pci_ids.h      2004-09-27 23:03:54 +01:00
@@ -734,6 +734,7 @@
 #define PCI_DEVICE_ID_TI_1251B         0xac1f
 #define PCI_DEVICE_ID_TI_4410          0xac41
 #define PCI_DEVICE_ID_TI_4451          0xac42
+#define PCI_DEVICE_ID_TI_4520          0xac46
 #define PCI_DEVICE_ID_TI_1410          0xac50
 #define PCI_DEVICE_ID_TI_1420          0xac51
 #define PCI_DEVICE_ID_TI_1451A         0xac52
Comment 1 Dax Kelson 2004-09-28 13:09:20 EDT
Created attachment 104447 [details]
Patch to add proper PCMCIA support for Thinkpad T42s
Comment 2 Warren Togami 2004-09-28 16:14:09 EDT
While this seems like an obviously good and easy change, it would
*really* help if you could please help to push it for upstream
inclusion.  It is already too late for FC3T3 but maybe we can get it
into FC3 final.
Comment 3 Dax Kelson 2004-09-29 23:57:20 EDT
Linus just releaesed 2.6.9-rc3. It has the fix.

(Bookmarkable bkbits link)

http://linus.bkbits.net:8080/linux-2.5/cset@4159eac6SsXcvCc_x3jv5F_LzGHONg?nav=index.html|ChangeSet@-2d
Comment 4 Deji 2004-10-15 15:25:58 EDT
Guess this can be closed now since the fix was reportedly fixed in
2.6.9-rc3', current devel kernel have 2.6.9-rc4. 

Note You need to log in before you can comment on or make changes to this bug.