Bug 1339582 - Firefox crashes on saving a jpg image file
Summary: Firefox crashes on saving a jpg image file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1339946 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-25 11:33 UTC by Bill
Modified: 2017-07-07 05:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-07 05:41:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Bill 2016-05-25 11:33:00 UTC
Description of problem:


Version-Release number of selected component (if applicable): gtk3 3.20.5


How reproducible: select any jpg image on a web site and "save As"


Steps to Reproduce:
1. Select a jpg image on a web page 
2. Save As

Actual results: The image is saved but firefox crashes


Expected results: The image is saved and firefox continues normally


Additional info:

The problem doesn't occur if the image file is a png file.

Problem can be resolved by downgrading gtk3 3.20.5 to gtk3 3.20.4.

Comment 1 Matthias Clasen 2016-05-25 19:28:44 UTC
this crash is fixed in gtk3-3.20.6

Comment 2 Dan Loomis 2016-05-27 03:25:13 UTC
*** Bug 1339946 has been marked as a duplicate of this bug. ***

Comment 3 Bill 2016-05-27 03:35:03 UTC
Confirmed that gtk3-3.20.6, which landed in updates-testing today, fixes the problem.


Note You need to log in before you can comment on or make changes to this bug.