Bug 133994 - keyboard type-ahead does not support substring activation
keyboard type-ahead does not support substring activation
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 16:53 EDT by Chris Lee
Modified: 2008-05-09 13:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 10:44:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Lee 2004-09-28 16:53:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040928 Firefox/0.10

Description of problem:
Keyboard type-ahead find should work more like Mozilla/Firefox and not
the way it currently works.

Currently, if three entries that start with the same letter exist in a
menu, I have to repeatedly press the letter that they start with in
order to activate one of them.

In menus where lots of entries start with the same letter, this makes
it tedious to activate an entry that is not the first one on the list.

Instead of jumping from entry to entry starting with the same first
letter, the panel should support typing the first few characters of
the string for the item.

So if I have:
IM
Instant Messenger
IRC

And I want to activate 'IRC' - I should be able to type 'IR' instead
of 'iii' to activate it.

Version-Release number of selected component (if applicable):
gnome-panel-2.8.0-1

How reproducible:
Always

Steps to Reproduce:
1. Click on a menu
2. Start typing
3. Note that typing subsets of strings does not activate the items
intended

Actual Results:  The menu jumps between entries starting with the same
letter

Expected Results:  The menu should activate whichever entry I'm
currently typing the name of.

Additional Info: The KDE panel and menus support this.
Comment 1 Mark McLoughlin 2004-09-29 10:44:00 EDT
Well, the idea is that the first letter in each menu item is used as a
mnemonic for that menu item - so its as if each menu item has the
first letter underlined, except its not actually underlined (if you
get my meaning). So, its just like normal GTK+ mnemonics.

On the other hand, it may be more intuitive to do it the way you
suggest since there is no actual visual hint that the first letters
are mnemonics. Moving UPSTREAM for discussion:

  http://bugzilla.gnome.org/show_bug.cgi?id=154060

One more data point - I think Windows does it exactly the same way we
do it now. The original bug report for the feature was "I want
Ctrl-Esc-r to launch the run dialog just like it does on Windows"

Note You need to log in before you can comment on or make changes to this bug.