Bug 134054 - anaconda ip= and pxelinux IPAPPEND option don't coexist peacefully
anaconda ip= and pxelinux IPAPPEND option don't coexist peacefully
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
FC4
:
Depends On:
Blocks: 132991
  Show dependency treegraph
 
Reported: 2004-09-29 06:22 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2005-220
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 10:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-pxelinux-ip-args.patch (2.07 KB, patch)
2004-10-13 08:37 EDT, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2004-09-29 06:22:15 EDT
Description of problem:
The "ip=" options used by PXE Linux and Anaconda are different, and
incompatible:
pxelinux: ip=<client-ip>:<boot-server-ip>:<gw-ip>:<netmask>
anaconda: ip=<client-ip> netmask=<nm> gateway=<gw> dns=<dns>

It looks like it could be easy to mix and match the 2, for example:
ip=<client-ip>:<boot-server>:<gw-ip>:<netmask> dns=<dns>

Anaconda could get the client IP, gateway IP and netmask from the PXE
Linux option by simply checking whether the string contains ":".

I can provide a patch if deemed necessary.
Comment 1 Jeremy Katz 2004-09-29 11:48:49 EDT
My ip= option predates the ipappend stuff from pxelinux :-)  I'm not
against adding support for parsing the format passed by pxelinux if
you want to provide a patch (would definitely get it in faster, too)
Comment 2 Bastien Nocera 2004-10-13 08:37:40 EDT
Created attachment 105141 [details]
anaconda-pxelinux-ip-args.patch

A patch for the loader to understand both pxelinux and anaconda style
formatting.
Some options obviously aren't used by anaconda. The parsing is ugly but pretty
solid.
Comment 4 Jeremy Katz 2004-11-07 13:50:12 EST
Thanks for the patch, committed to HEAD.

Leaving open to investigate for RHEL updates
Comment 8 Jeremy Katz 2005-01-06 14:50:51 EST
Committed for RHEL3 U5, any testing would be much appreciated.
Comment 9 Dennis Gregorovic 2005-05-18 10:28:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2005-191.html

Note You need to log in before you can comment on or make changes to this bug.