Bug 134109 - The window list applet should be "locked" as default
Summary: The window list applet should be "locked" as default
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-29 17:12 UTC by Kyrre Ness Sjøbæk
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-28 13:27:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kyrre Ness Sjøbæk 2004-09-29 17:12:08 UTC
Description of problem:
The window list applet, which lists open windows, are by default not
locked - which means it could be very easily removed by accident by
unaccustomed gnome users. I have personally withnessed this happen
several times. - making the user effectively *very* confused,
beleiving that the "minimize" button is the "close" button, and
because of that, believes the myth that Linux is hard to use.

Version-Release number of selected component (if applicable):
gnome-desktop-2.7.92-1

How reproducible:
Every time

Steps to Reproduce:
1. Create a user (or install FC - as this will create a user)
2. Be stupid/unaccustomed and accidentally remove the windowlist applet
3. *confused*
  
Actual results:
Huge confusion

Expected results:
The windowlist applet should be "locked" - as the clock, the RH menu etc.

Additional info:

Should be a relatively easy fix?

Comment 1 Mark McLoughlin 2004-09-29 17:59:13 UTC
Bryan, Seth: any opinions on this ?

Comment 2 Bryan W Clark 2004-09-29 18:17:19 UTC
Locked by default does sound reasonable. However doesn't the panel
allow you to remove items that are locked anyway?  I don't see how
this would fix the problem reported.

Or are you talking about locked-down?  As in the user has no control
over it.  That is supposed to be an administrative feature that I
don't think would be a reasonable default for FC.

Comment 3 Kyrre Ness Sjøbæk 2004-09-29 18:46:09 UTC
No not talking about locked down. Hmm.. I think locked also locked
"remove from panel" in gnome 2.6...

Maybe not. Maybe they dragged it off somewhere or something. But then
the main problem is that it is possible to kill off applets that are
locked?

You have no clue about how many b0rked dockbars iv'e seen. It seems
even KDE has this problem - i once saw a (german) SuSE machine with no
window-list...

Comment 4 Bryan W Clark 2004-10-15 06:49:53 UTC
mark, I'm pretty sure this is how the default config was done.  Close
away if true.

Comment 5 Mark McLoughlin 2004-10-28 13:27:32 UTC
Yeah, everything but the launchers are locked in the default config now.


Note You need to log in before you can comment on or make changes to this bug.