Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1341638 - When exporting anything to text/pdf/csv, then favicon in firefox is missing.
Summary: When exporting anything to text/pdf/csv, then favicon in firefox is missing.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: GA
: 5.7.0
Assignee: Dávid Halász
QA Contact: Matouš Mojžíš
URL:
Whiteboard: ui
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-01 11:45 UTC by Matouš Mojžíš
Modified: 2016-06-22 14:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-22 14:24:08 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
before downloading (57.45 KB, image/png)
2016-06-02 16:49 UTC, Matouš Mojžíš
no flags Details
after downloading no favicon (57.32 KB, image/png)
2016-06-02 16:50 UTC, Matouš Mojžíš
no flags Details

Description Matouš Mojžíš 2016-06-01 11:45:43 UTC
Description of problem:
When I export for example list of providers to text/pdf/csv, then favicon in firefox is missing. Source code of page is same as before and it doesn't dissapear in chromium, so I think this is firefox feature, that it doesn't show favicons after downloading anything. 

Version-Release number of selected component (if applicable):
5.6.0.8

How reproducible:
Always

Steps to Reproduce:
1. Export (for example Compute-> Cloud -> Providers and export data to text)
2. Favicon is missing and I have to refresh or load some other page
3.

Actual results:
Missing favicon in firefox 

Expected results:


Additional info:

Comment 2 Harpreet Kataria 2016-06-02 15:29:13 UTC
Matous,

Can you provide some more info along with screenshot of the issue. Do you see favicon missing in the UI or from exported files, currently we don not support favicon image in downloadable files.

Thanks,
~Harpreet

Comment 3 Matouš Mojžíš 2016-06-02 16:48:41 UTC
I don't see it in firefox pannels. 
I have made two screenshots. One is before downloading and second is after downloading.

Comment 4 Matouš Mojžíš 2016-06-02 16:49:30 UTC
Created attachment 1164126 [details]
before downloading

Comment 5 Matouš Mojžíš 2016-06-02 16:50:19 UTC
Created attachment 1164127 [details]
after downloading no favicon

Comment 6 Harpreet Kataria 2016-06-03 16:06:05 UTC
David,

Can you please look into this, looks like after download button is pressed anywhere in UI, favicon disappears from browser title.

Thanks,
~Harpreet

Comment 8 Matouš Mojžíš 2016-06-22 14:12:00 UTC
It's impossible.
I tried the same thing with 5.6.0.8 and I can't reproduce it.
Maybe it's fixed in the newest firefox.


Note You need to log in before you can comment on or make changes to this bug.