Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 134168 - Spellchecking in emacs with aspell on tex document fails
Spellchecking in emacs with aspell on tex document fails
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: aspell (Show other bugs)
2
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-29 17:39 EDT by roger griffiths
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-06 16:16:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description roger griffiths 2004-09-29 17:39:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3)
Gecko/20040921

Description of problem:
Probably not a bug, I must have something configured incorrectly, but...

I am having the same symtoms reported in Bug #54391 (which was
resolved last year)
When I spell check any .tex file, I get a core dump and the emacs
process runs away (100% CPU) and have to kill the process.

The interesting part is that if I create a very simple file, say
'test.txt' and spell check (from within emacs) aspell works fine. If I
copy that same file to test.tex and then try to spell check the file I
get the hung process. Finally, copy the file to test.html, aspell
works fine.

I tried this simple method to identify if there was some characters
within my tex documents that was causing aspell trouble.

The core dumps are attributed to aspell,
 libaspell.so.15
aerror_bad_input
(corruped library?)

Version-Release number of selected component (if applicable):
emacs-21.3-12; aspell-0.50.3-19.1

How reproducible:
Always

Steps to Reproduce:
1.As outlined above - create a file with just four lines of text, save
the file as test.txt; spell check the file (from within emacs) - no
problems.
2.Copy the above file to test.tex (at the command line), open in
emacs, try to spell check, I get a core dump (aspell) and then have to
kill the emacs process.
3. Copy the same file to test.html, open in emacs, spell check no
problems.
    

Additional info:
Comment 1 Jens Petersen 2004-10-06 04:28:28 EDT
Looks like this is probably an aspell bug on x86_64.

Seems to be ok with rawhide/fc3 test releases afaics.
Comment 2 Eido Inoue 2004-10-06 16:16:46 EDT
can't reproduce with my machines; i'm not seeing this on current
x86_64 builds either.

Note You need to log in before you can comment on or make changes to this bug.