Bug 134206 - hangul input not working, oowrite crashes at start
hangul input not working, oowrite crashes at start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Leon Ho
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-30 02:47 EDT by Kyuso Cahi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 21:24:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyuso Cahi 2004-09-30 02:47:29 EDT
Description of problem:

OpenOffice only puts a blank grey space when hangul input key (CTRL-SPACE)
is pressed, and no hangul input is done. FC1 had no problem using ami
input method. I had updated xorg-x11 to 6.7.0-9 and iiimf to 11.4-46.1
(it seems 11.4-46 conflicts instead of cleanly upgrades when
installing 11.4-46.1). I never tried previous/original versions that
came from install media.

oowrite consistently crashes as soon as the first window is opened.

OpenOffice 1.1.2 stock download install always crashes at install
dialog asking install directory, when 'Browse' or pathname pressed. If
'Next' pressed, it works, but then subsequent ooffice crashes as soon
as 'Accept License...' and 'Next' is pressed.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.1-4 or openoffice.org-1.1.2
iiimf-le-hangul-11.4-46.1.svn1587
xorg-x11-6.7.0-9

How reproducible:
always

Steps to Reproduce:
1. set language to hangul from KDE or GNOME settings
2. run ooffice
3. press CTRL-SPACE and type some characters
  
Actual results:
Only grey space is entered

Expected results:
Hangul characters should be displayed

Additional info:
Also, when invoking oowrite directly instead of from ooffice, it
always crashes as soon as it opens a blank window.

Furthermore, trying to install OpenOffice 1.1.2 from stock downloaded
installation from openoffice.org crashes at the install dialog where
it asks for installation directory, whenever the 'Browse' button or
the pathname is pressed. If Next is pressed, it works.
But then subsequent soffice command crashes as soon as the first blank
window opens.

All of the FC2 updates were applied dated up to 9/29/2004.
Comment 1 Dan Williams 2004-09-30 15:23:54 EDT
Please try an updated 1.1.2-6 from Rawhide.  Also bugs against the
Stock OOo need to go to www.openoffice.org
Comment 2 Kyuso Cahi 2004-10-01 13:54:06 EDT
I found the problem to be exclusive to updated iiimf*-11.4-46.svn1587
or iiimf*-11.4-46.1.svn1587 from fc2 update. I reverted back to
iiimf*-11.4-43 from original fc2 and everything works perfectly.

So My guess is iiimf*-11.4-46{.1}.svn1587 somehow breaks
openoffice.org in unexpected ways. I was assuming the update were
tested and stable.

I am happy with original iiimf*-11.4-43 for now.

I will test rawhide openoffice and iiimf after I feel confident to
install all dependencies.

Also, even though the component of this bug is set to openoffice.org,
I believe it should be set to iiimf, or both, since the bug seems to
be an inter-operation of the two.
Comment 3 Dan Williams 2004-10-05 10:50:59 EDT
Over to you Leon... Can you test with 1.1.2-7?  That will be released
as an FC2 update soon.
Comment 4 Leon Ho 2004-10-05 11:26:45 EDT
Kyuso, if you can try OOo 1.1.2-5 or 6 then it should be much better
as it is using iiimgcf.

Dan, 1.1.2-{5,6} should be a better candidate for FC2 update. There is
a big i18n problem on 1.1.2-7 - please see Bug 134505.
Comment 5 Kyuso Cahi 2004-10-08 12:43:55 EDT
where can I get the openoffice.org 1.1.2-* for fc2? fc2 test download site

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/

seems quite old compared to even fc2 update.
Comment 6 Leon Ho 2004-10-21 21:24:32 EDT
Thanks to Dan - you should able to see openoffice.org-1.1.2-10 in fc2
updates now.

Note You need to log in before you can comment on or make changes to this bug.