Bug 1342106 - Registering VM with snapshots fails
Summary: Registering VM with snapshots fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.0.1
: 4.0.0
Assignee: Tal Nisan
QA Contact: Elad
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-02 12:48 UTC by Tal Nisan
Modified: 2016-07-19 06:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 06:24:52 UTC
oVirt Team: Storage
rule-engine: ovirt-4.0.z+
rule-engine: planning_ack+
tnisan: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 58537 0 master MERGED core: Fix error in register VM with snapshots 2016-06-02 13:51:36 UTC
oVirt gerrit 58545 0 ovirt-engine-4.0 MERGED core: Fix error in register VM with snapshots 2016-06-02 13:51:52 UTC

Description Tal Nisan 2016-06-02 12:48:51 UTC
Description of problem:
When trying to register a VM with snapshot the operation fails

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create a VM with disks on a specific storage domain and take a snapshot
2. Move the domain containing the disks to maintenance and detach it 
3. Re-attach the domain and try to register the VM

Actual results:
The VM registration fails

Expected results:
The VM registration should succeed

Additional info:

Comment 1 Gilad Lazarovich 2016-06-19 06:32:23 UTC
Re-opening the bug, I get an exception as soon as I try to import the VM from the storage domain that was placed in maintenance. This is with build rhevm-4.0.0.4-0.1. The UI error notes: "Uncaught exception occurred. Please try reloading the page."

Comment 2 Red Hat Bugzilla Rules Engine 2016-06-19 06:32:29 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 3 Allon Mureinik 2016-06-19 09:46:50 UTC
(In reply to Gilad Lazarovich from comment #1)
> Re-opening the bug, I get an exception as soon as I try to import the VM
> from the storage domain that was placed in maintenance. This is with build
> rhevm-4.0.0.4-0.1. The UI error notes: "Uncaught exception occurred. Please
> try reloading the page."

Logs?

Comment 5 Tal Nisan 2016-06-26 11:09:25 UTC
Please check again, there is a UI exception regardless to the function of the import which works as it should, I will open another bug on the UI exceptions (actually two different ones), this bug should be used only for the import a VM with snapshots

Comment 7 Elad 2016-07-10 11:55:20 UTC
Import of VM with snapshot from an imported data domain works as expected. 
I get Uncaught exceptions in UI:

SEVERE: Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: b is null

But these are not in the scope of this bug as mentioned in comment #5 so don't block verification here.


Tested using:
rhevm-4.0.0.6-0.1.el7ev.noarch
vdsm-4.18.4-2.el7ev.x86_64

Comment 8 Sandro Bonazzola 2016-07-19 06:24:52 UTC
Since the problem described in this bug report should be
resolved in oVirt 4.0.1 released on July 19th 2016, it has been closed with a
resolution of CURRENT RELEASE.

For information on the release, and how to update to this release, follow the link below.

If the solution does not work for you, open a new bug report.

http://www.ovirt.org/release/4.0.1/


Note You need to log in before you can comment on or make changes to this bug.