Bug 134228 - assertion failures, critical warnings, etc on stderr
Summary: assertion failures, critical warnings, etc on stderr
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gpdf   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-30 13:56 UTC by Tim Waugh
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-06 14:51:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2004-09-30 13:56:29 UTC
Description of problem:
Just starting and stopping gpdf causes lots of spewages to stderr.

Version-Release number of selected component (if applicable):
2.8.0-1

How reproducible:
100%

For example:

(gpdf:18880): Bonobo-CRITICAL **: file bonobo-widget.c: line 325
(bonobo_widget_get_control_frame): assertion `BONOBO_IS_WIDGET
(bonobo_widget)' failed

(gpdf:18880): Bonobo-CRITICAL **: file bonobo-control-frame.c: line
571 (bonobo_control_frame_set_autoactivate): assertion
`BONOBO_IS_CONTROL_FRAME (frame)' failed

(gpdf:18880): Bonobo-CRITICAL **: file bonobo-widget.c: line 325
(bonobo_widget_get_control_frame): assertion `BONOBO_IS_WIDGET
(bonobo_widget)' failed

(gpdf:18880): Bonobo-CRITICAL **: file bonobo-control-frame.c: line
533 (bonobo_control_frame_control_deactivate): assertion
`BONOBO_IS_CONTROL_FRAME (frame)' failed

(gpdf:18880): Bonobo-WARNING **: Non-toolbar parent '<NULL-instance>'

(gpdf:18880): Bonobo-CRITICAL **: file
bonobo-ui-toolbar-control-item.c: line 107
(impl_toolbar_reconfigured): assertion `toolbar != NULL' failed

Comment 1 Dan Williams 2004-09-30 14:19:52 UTC
I blame this on recent libbonoboui crashes and problems...

Comment 2 Marco Pesenti Gritti 2004-11-06 14:51:22 UTC
Moved upstread since it's consistently reproducable also on a jhbuild
tree.

http://bugzilla.gnome.org/show_bug.cgi?id=156775


Note You need to log in before you can comment on or make changes to this bug.