Bug 134251 - Requires desktop-file-utils needs to be >= 0.8
Requires desktop-file-utils needs to be >= 0.8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: file-roller (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-30 12:11 EDT by Robert Hardy
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-27 12:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Hardy 2004-09-30 12:11:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040919
Firefox/0.10

Description of problem:
This rpm has a requires of "desktop-file-utils >= 0.2.90" and yet it
calls the "update-desktop-database" command which is
only available in much later versions.

Please update the requires to a version which has
update-desktop-database. A requires of "desktop-file-utils >= 0.8"
would probably work.

I haven't been able to determine exactly when this command was added
to desktop-file-utils. The rpm changelog doesn't help.

Fedora Core 2 includes: desktop-file-utils-0.4-2.i386.rpm
Rawhide recently had: desktop-file-utils-0.9-1.i386.rpm

The update-desktop-database command is present in 0.8-4.
The update-desktop-database command is not present in 0.4-2.


Version-Release number of selected component (if applicable):
2.8.0-2

How reproducible:
Always

Steps to Reproduce:
1. Have an older desktop-file-utils installed ex. from FC2.
2. Install/Upgrade to reference RPM
3. Scripts complain about missing "update-desktop-database" command


Actual Results:  Scripts fail and complain about missing
"update-desktop-database" command.


Expected Results:  Install/Upgrade should complain my
desktop-file-utils is too old.



Additional info:
Comment 1 Marco Pesenti Gritti 2004-10-27 12:28:41 EDT
Already fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.