Bug 134259 - Running either redhat-config-printer and -printer-gui programs results in the program not executing and some dump in terminal
Running either redhat-config-printer and -printer-gui programs results in the...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: redhat-config-printer (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-30 13:17 EDT by Gian Paolo Mureddu
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 08:30:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2004-09-30 13:17:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Soon after updating the packages via yum, it was impossible to execute
both the confguration tools. Running them through a terminal to see
what got printed to stdout, here's what either applications dumps:

redhat-config-printer-gui:

<code>
admindir /var/lib/alternatives invalid
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer-gui", line 7, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 1091, in ?
    queueTree()
  File "/usr/share/printconf/util/queueTree.py", line 128, in __init__
    if cups_import.import_needed ():
  File "/usr/share/printconf/util/cups_import.py", line 200, in
import_needed
    which = which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment
</code>

And redhat-config-printer:

<code>
admindir /var/lib/alternatives invalid
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 1091, in ?
    queueTree()
  File "/usr/share/printconf/util/queueTree.py", line 128, in __init__
    if cups_import.import_needed ():
  File "/usr/share/printconf/util/cups_import.py", line 200, in
import_needed
    which = which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment
</code>

Both errors are virtually identical, leading me to believe the problem
may have something to do with Python or some other library. I haven't
been able to find any reports of similar problems, nor have I access
to other FC1 machines to try and stablish a reproduciblity rate.
Though this happens everytime I try to run these programs in the computer.

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.79.5-1 redhat-config-printer-gui-0.6.79.5-1

How reproducible:
Always

Steps to Reproduce:
1.After upgrading packates through yum to the latest versions
2.Run the program from console and you'll get the error messages above.
3.
    

Actual Results:  This has always lead to the error messages I've
already posted above. Even after uninstalling and re-installing the
packages altogether.

Additional info:

Though this is no showstopper, by any means, at least in my case I
consider this bug with a somewhat high priority, because I need
printing to be available on my Fedora Core 1 machine.
Comment 1 Tim Waugh 2004-09-30 13:30:02 EDT
What does '/sbin/alternatives --display print' say?
Comment 2 Gian Paolo Mureddu 2004-10-19 14:10:54 EDT
Sorry for the late (too late) response, when I run the above command I
get:

/sbin/alternatives: No such file or directory.

Looking around I found it to be under /usr/sbin/, and when ran with
--display print as its arguments I get nothing. Just a new line.
Comment 3 Tim Waugh 2004-12-03 08:30:29 EST
Sounds like the %post install scriptlet for CUPS didn't get run.  Try
re-installing the cups RPM (rpm -Uvh --force cups-1*.rpm).

Note You need to log in before you can comment on or make changes to this bug.