Bug 134266 - initlabel and changing partition table don't mix
initlabel and changing partition table don't mix
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda (Show other bugs)
2.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 134708 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-30 14:20 EDT by Michael Blandford
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 16:57:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Blandford 2004-09-30 14:20:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
If I use clearpart --all --initlabel and have the partition table
change in the partition section from what it was previously, various
errors occur.

These may include telling you some partitions are too small, swap
errors, etc.

Rebooting and starting again will clear up the errors.

It would appear that kernel doesn't realize the partitions have
changed and is still using the old information.

Simply removing the --initlabel flag will clear up this problem, but
then you may get asked questions during the install which is also not
desireable.




Version-Release number of selected component (if applicable):
anaconda-7.3-14.WS

How reproducible:
Always

Steps to Reproduce:
1. Install AW2.1 via kickstart using some partition table
2. Rebuild using the same process, use --initlabel, change the
partition table
3. Various errors pop up during the install regarding partitions too
small, couldn't initialize swap, etc.
    

Actual Results:  Install halts looking for interaction

Expected Results:  Completely unattended installs.

Additional info:

This only seems to happen on ia64.  I do not have similar results on ia32.
Comment 1 Jeremy Katz 2004-09-30 16:57:14 EDT
This seems fine on newer code.  The simple workaround for 2.1 is to
not do that (if you need to initialize, you can do a dd in your %pre)
Comment 2 Jeremy Katz 2004-10-05 14:30:18 EDT
*** Bug 134708 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.