Bug 134282 - ccsd allows ports to be given as chars and then sets them 0
Summary: ccsd allows ports to be given as chars and then sets them 0
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs   
(Show other bugs)
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Earl Brassow
QA Contact: GFS Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-30 21:11 UTC by Corey Marthaler
Modified: 2010-01-12 02:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-27 18:57:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Corey Marthaler 2004-09-30 21:11:55 UTC
Description of problem:
I passed into ccs ports which were characters to see what would happen
and ccs then turns all chars to 0 somehow with the atoi function.  
This is bad because it allow ccs to run and appear alright
however any connection attempt will hang.   

I added debugging to ccsd.c to see what the args were before and after
the atoi function:

[root@morph-03 daemon]# ccsd -P c:H -P b:V -P f:J
cluster_base_port=H
cluster_base_port=0
backend_port=V
backend_port=0
frontend_port=J
frontend_port=0

[root@morph-03 daemon]# ps -ef | grep ccsd
root     11656     1  0 15:36 ?        00:00:00 ccsd -P c:H -P b:V -P f:J

[root@morph-03 daemon]#  ccs_test connect
<hangs>

How reproducible:
Always

Comment 1 Jonathan Earl Brassow 2004-10-14 22:04:09 UTC
Fixed

Comment 2 Corey Marthaler 2004-10-27 18:57:45 UTC
fix verified.

Comment 3 Kiersten (Kerri) Anderson 2004-11-16 19:03:10 UTC
Updating version to the right level in the defects.  Sorry for the storm.


Note You need to log in before you can comment on or make changes to this bug.