Bug 134348 - dbus - unknown user root - crash
dbus - unknown user root - crash
Status: CLOSED DUPLICATE of bug 134347
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-01 11:26 EDT by Sammy
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2004-10-01 11:26:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; en_US) (KHTML, like Gecko)

Description of problem:
During system start messagebus is crashing with the message:

dbus-daemon-1: Unknown username "root" in message bus configuration file
dbus-daemon-1: *** glibc detected *** corrupted double-linked list: 0x081fdf00 ***

the first is coming from two files cups.conf and hal.conf in /etc/dbus-1/system.d
directory. They refer to user root. When these two files are removed the message
bus starts without the first error. I am not sure about the glibc one.

I am running rawhide of Oct. 1 and with selinux disabled.

Is this a dependency missing or something else? Thanks.

Version-Release number of selected component (if applicable):
dbus-0.22-9

How reproducible:
Always

Steps to Reproduce:
1.update all to latest rawhide
2.reboot system
3.
    

Additional info:
Comment 1 John (J5) Palmieri 2004-10-01 17:53:50 EDT

*** This bug has been marked as a duplicate of 134347 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.