Bug 134361 - dos2unix fails on diffrent mount point
dos2unix fails on diffrent mount point
Status: CLOSED DUPLICATE of bug 123069
Product: Fedora
Classification: Fedora
Component: dos2unix (Show other bugs)
2
All Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-01 13:33 EDT by Nils O. Selåsdal
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils O. Selåsdal 2004-10-01 13:33:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
dos2unix fails converting a file on a diffrent filesystem, and it erases 
the original file.


Version-Release number of selected component (if applicable):
dos2unix-3.1-19

How reproducible:
Always

Steps to Reproduce:

I'm trying to convert a file on a filesystem residing under /mnt/xeena
while I'm at ~ :

1.$ dos2unix /mnt/xeena/45
dos2unix: converting file /mnt/xeena/45 to UNIX format ...
dos2unix: problems renaming './u2dtmp26j0Az' to '/mnt/xeena/45'
          output file remains in './u2dtmp26j0Az'
dos2unix: problems converting file /mnt/xeena/45

    

Actual Results:  /mnt/xeena/45 is deleted.

Expected Results:  /mnt/xeena/45 to be converted ;)

Additional info:

Seems the failure is calling rename(2) between filesystems.
Comment 1 Mike A. Harris 2004-10-06 16:14:01 EDT

*** This bug has been marked as a duplicate of 123069 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.