Bug 1343714 - rhel-osp-director: 7.3->8.0 upgrade of deployment with external ceph. The /etc/ceph/ceph.conf on compute lists wrong monitors.
Summary: rhel-osp-director: 7.3->8.0 upgrade of deployment with external ceph. The /e...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: async
: 10.0 (Newton)
Assignee: Giulio Fidente
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-07 18:21 UTC by Alexander Chuzhoy
Modified: 2016-07-19 20:59 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 20:59:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alexander Chuzhoy 2016-06-07 18:21:01 UTC
rhel-osp-director:  7.3->8.0 upgrade of deployment with external ceph. The /etc/ceph/ceph.conf on compute lists wrong monitors.

Environment:
instack-undercloud-2.2.7-7.el7ost.noarch
openstack-tripleo-heat-templates-0.8.14-13.el7ost.noarch
openstack-tripleo-heat-templates-kilo-0.8.14-13.el7ost.noarch
openstack-puppet-modules-7.0.19-1.el7ost.noarch


Steps to reproduce:
1. Deploy 7.3 with external ceph.
2. Populate the overcloud (successfully launch an instance residing on external ceph)
3. Upgrade the setup to 8.0
4. Attempt to launch another instance

Result:
The instance goes into error state.

Checking the /etc/ceph/ceph.conf file on compute:
[global]
osd_pool_default_pgp_num = 32
osd_pool_default_min_size = 1
auth_service_required = cephx
fsid = 1c50eddf-56fb-470f-a72d-47a960f520a0
auth_supported = cephx
auth_cluster_required = cephx
mon_host = 192.168.110.13,192.168.110.12,192.168.110.11
auth_client_required = cephx
osd_pool_default_size = 3
osd_pool_default_pg_num = 32
ms_bind_ipv6 = False

[osd]
osd_journal_size = 1024

The mon_host lines actually contains IP addresses of controllers.

Workaround:
On computes replace the IP addresses in the mon_host line with the IP address of external ceph monitors and restart systemctl restart openstack-nova-compute.service

Comment 5 Alexander Chuzhoy 2016-07-11 17:58:58 UTC
Deployment command:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 1 --swift-storage-scale 0 --block-storage-scale 0 --neutron-tunnel-types vxlan,gre --neutron-network-type vxlan,gre --neutron-network-vlan-ranges datacentre:118:143 --neutron-bridge-mappings datacentre:br-ex  --ntp-server clock.redhat.com --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml -e ~/ssl-heat-templates/environments/enable-tls.yaml -e ~/ssl-heat-templates/environments/inject-trust-anchor.yaml --ceph-storage-scale 0 -e puppet-ceph-external.yaml

Comment 6 Giulio Fidente 2016-07-11 18:02:45 UTC
Assuming we were using the same environment file for both the initial deployment and the upgrade, could you attach the environment file with the external-ceph parameters and paste the upgrade cmdline?

Comment 9 Alexander Chuzhoy 2016-07-19 20:59:55 UTC
Indeed the upgrade command was missing some of the templates used to deploy.
Once added, was able to successfully upgrade.
Closing as not a bug.
Thanks Giulio!


Note You need to log in before you can comment on or make changes to this bug.