Bug 134435 - Various Gnome-components (i.e. Nautilus) die unexpectedly ("assertion ... failed")
Summary: Various Gnome-components (i.e. Nautilus) die unexpectedly ("assertion ... fai...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-02 16:09 UTC by Bas van Schaik
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 2.8 (FC3test3)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 08:19:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bas van Schaik 2004-10-02 16:09:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10.1

Description of problem:
Nautilus seems to work properly (i.e. I can use it as a file manager,
open directories, copy/move/rename files, etc), but if you try to do
slight complex things with it (like opening the "Properties"-window of
a file or directory) it crashes. Gnome tells me:
----- Begin quote -----
The Application "nautilus" has quit unexpectedly.

You can inform the developers of what happened to help them fix it. Or
you can restart the application right now.
----- End quote -----
(window with two buttons: "Restart Application" and "Close")


I tried to gather some more information about this crash (which
*always* occurs) by starting nautilus via the Gnome Terminal. No
output is given there at all (using my own account). But when I "su"
first and then try to start nautilus, the output becomes:

----- Begin quote ------
[bas@farquaad ~]$ su
Password:
[root@farquaad bas]# nautilus

(nautilus:4641): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols
specified are supported and host-based authentication failed.
added /media/* to excludes
added /mnt/* to excludes
looking for type: got text/plain
looking for type: got text/plain
looking for type: got application/x-gnome-app-info
Adding /root/Templates to polling
switching /root back to polling
Adding /root to polling
switching /root back to kernel monitoring
Removing /root from polling
Removing /root from polling
Removing /root/Azureus from polling
----- End quote -----

And when I try to open the "Properties"-dialog of a file or directory,
the following gets added to the console output:

----- Begin quote -----
nautilus: art_render_gradient.c:337:
art_render_gradient_linear_render_8: Assertion `(stops[ix-1].offset <=
offset_fraction + 1e-6) || ((stops[ix].offset > (1.0 - 1e-6)) &&
(offset_fraction < 1e-6 ))' failed.
switching /root back to polling
Adding /root to polling
switching /root back to kernel monitoring
Removing /root from polling
Removing /root from polling
----- End quote -----

And, of course, followed by the usual "The application 'Nautilus' has
quit unexpectedly"-dialog.

I first ran into this problem after upgrading to FC3test1 (I cannot
remember which version of nautilus was included in that distribution),
but I didn't file a bug report against it because I was hoping this
was fixed in test2. 

Same problem while using the gnome-background-properties utility (and
all the other stuff from the Control Panel). While invoked from a
terminal as a normal user: no output, but when invoked by root:

----- Start quote -----
(gnome-background-properties:4879): GnomeUI-WARNING **: While
connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols
specified are supported and host-based authentication failed.
*** attempt to put segment in horiz list twice
*** attempt to put segment in horiz list twice
gnome-background-properties: art_render_gradient.c:337:
art_render_gradient_linear_render_8: Assertion `(stops[ix-1].offset <=
offset_fraction + 1e-6) || ((stops[ix].offset > (1.0 - 1e-6)) &&
(offset_fraction < 1e-6 ))' failed.
----- End quote -----

I don't have enough experience with C to check the sources for
problems myself, but I am sure some people here have!

Version-Release number of selected component (if applicable):
Various versions (i.e. nautilus-2.7.92-3), but had this problem with
older -fc3test1- versions too

How reproducible:
Always

Steps to Reproduce:
1. Start nautilus
2. Right click on a file or directory
3. Choose "Properties"
4. -- CRASH --

1. Start Control Panel (gnome-control-center)
2. Try to use one of the utilities listed (i.e. "Desktop Background")
or start one of the utilities manually (i.e.
"gnome-background-properties")
3. -- CRASH --
    

Actual Results:  Something similar to this (details depend on the
application used), but the output always ends with "Assertion ...
failed" in the file "art_render_gradient.c" on line 337

---- Begin quote ----
(gnome-background-properties:4879): GnomeUI-WARNING **: While
connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols
specified are supported and host-based authentication failed.
*** attempt to put segment in horiz list twice
*** attempt to put segment in horiz list twice
gnome-background-properties: art_render_gradient.c:337:
art_render_gradient_linear_render_8: Assertion `(stops[ix-1].offset <=
offset_fraction + 1e-6) || ((stops[ix].offset > (1.0 - 1e-6)) &&
(offset_fraction < 1e-6 ))' failed.
----- End quote -----

Expected Results:  Nautilus showing me properties of a file or
directory, gnome-background-properties showing up, etc.

Additional info:

While searching the internet (including this bugzilla database), I
found some other nautilus-crash-problems, but I don't think those
reports are related to my problem.

Comment 1 Alexander Larsson 2004-10-04 07:45:52 UTC
This seems like a problem rendering some SVG. Could you try to figure
out what svg file is causing this and attach it here?


Comment 2 Bas van Schaik 2004-10-04 07:55:47 UTC
I'm sorry, I can't see anything: the application crashes before a
window shows up, so I can't figure out which SVG-file is causing
nautilus (and others) to crash. Logical thinking says that this image
is both used in the Properties-dialog of a file/directory and in the
gnome-background-properties utility. But since I can't use both
programs I'm unable to check which image this should be. Maybe you can
give me a hint, then I'll replace the image in question and test again.

Comment 3 Alexander Larsson 2004-10-04 11:20:05 UTC
Maybe we can see it in the backtrace.
Install debuginfo packages for eel2, nautilus, libart, librsvg, gtk2,
and glib2. Then generate stack traces according to:

http://fedora.linux.duke.edu/wiki/StackTraces

Comment 4 Alexander Larsson 2004-10-05 13:35:49 UTC
The background setting app might fail due to some background image svg
file causing the crash.

For nautilus, could you try to bring up the Edit -> backgrounds and
emblems dialog and see if that crashes?

Comment 5 Alexander Larsson 2004-10-05 13:36:32 UTC
(And, please try to generate stacktraces for the crash)

Comment 6 Bas van Schaik 2004-10-14 08:19:50 UTC
Sorry, I didn't have the time to generate stacktraces on this crash,
but after updating my system to FC3test3 the problem was solved! I can
do anything with nautilus again! To be sure, I checked the console
output, and there's nothing weird there anymore!


Note You need to log in before you can comment on or make changes to this bug.