Bug 134468 - null argument where non-null required
Summary: null argument where non-null required
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-03 11:49 UTC by David Binderman
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 04:59:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Binderman 2004-10-03 11:49:52 UTC
Description of problem:

I just tried to compile package xorg-x11-6.8.0-4 from
Redhat Fedora Core 3 Test 2.

The compiler said

1.

sm_client.c:239: warning: null argument where non-null required (arg 2)

The source code is

                STORE_ARRAY8 (pData, 0, NULL);

I think this code needs rework.

2.

pm.c:231: warning: null argument where non-null required (arg 1)
pm.c:241: warning: null argument where non-null required (arg 1)
pm.c:307: warning: null argument where non-null required (arg 1)
pm.c:318: warning: null argument where non-null required (arg 2)

More of the same.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Warren Togami 2004-10-05 04:59:10 UTC
Thank you for your concern, but this is really a wrong place to file
bugs for mere compiler warnings unless you prove that it solves a real
problem.  In any case you should really file this at the upstream xorg
project, because there it is more likely to be reviewed.


Note You need to log in before you can comment on or make changes to this bug.