Bug 134477 - pam_console.dev does not handle device with multi symlink
Summary: pam_console.dev does not handle device with multi symlink
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 134478
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-03 17:24 UTC by Féliciano Matias
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: udev-032-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 13:58:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
provide multi file support to pam_console_setowner. (893 bytes, patch)
2004-10-03 17:28 UTC, Féliciano Matias
no flags Details | Diff
fix for pam_console.dev (need the previous patch) (525 bytes, patch)
2004-10-03 17:29 UTC, Féliciano Matias
no flags Details | Diff

Description Féliciano Matias 2004-10-03 17:24:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
If there are multi links in the udev rule, for example SYMLINK="dvdrom
dvd" then the permissions are not correctly set because
pam_console_setowner si not correctly call.


Version-Release number of selected component (if applicable):
udev-032-7

How reproducible:
Always

Steps to Reproduce:
modprobe ide-cd (i know, ide-cd is build-in in the fedora kernel...)

Actual Results:
pam_console_setowner called with "dvdrom dvd"

Expected Results:pam_console_setowner called with "dvdrom" then "dvd".

Comment 1 Féliciano Matias 2004-10-03 17:28:05 UTC
Created attachment 104680 [details]
provide multi file support to pam_console_setowner.

This patch provide multi file support to pam_console_setowner.

Comment 2 Féliciano Matias 2004-10-03 17:29:52 UTC
Created attachment 104681 [details]
fix for pam_console.dev (need the previous patch)

fix pam_console.dev. Use the multi file capability of the previous patch.

Comment 3 Féliciano Matias 2004-10-03 17:42:59 UTC
This bug depend on :
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=134478

Comment 4 Harald Hoyer 2004-10-04 12:34:14 UTC
Please post your patches to linux-hotplug-devel@lists.sourceforge.net

Comment 5 Féliciano Matias 2004-10-04 12:55:03 UTC
pam_console.dev and pam_console_setowner is not in udev.
It's a Red Hat patch.

So, reopen :-)

If I am wrong (or for any other raisons), close it again.

Comment 6 Harald Hoyer 2004-10-04 13:33:03 UTC
applied, thx! /me should read more carefully! need coffee..


Note You need to log in before you can comment on or make changes to this bug.