Bug 134478 - udev does not handle correctly multi link
Summary: udev does not handle correctly multi link
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 134477
TreeView+ depends on / blocked
 
Reported: 2004-10-03 17:39 UTC by Féliciano Matias
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 12:35:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for symlink handling. The patch apply to a patched udev (rh patchs). (1.83 KB, patch)
2004-10-03 17:40 UTC, Féliciano Matias
no flags Details | Diff

Description Féliciano Matias 2004-10-03 17:39:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
udev does not handle correctly multi links.

example : SYMLINK="dvdrom dvd cdrom%e"

udev call programs in /etc/dev.d with the environment variable SYMLINK
set to "/dev/dvdrom dvd cdrom" and not "/dev/dvdrom /dev/dvd /dev/cdrom"

for "%e", in this exemple, udev try to find the next value of "dvdrom
dvd cdrom" and not of "cdrom".

Version-Release number of selected component (if applicable):
udev-032-7

How reproducible:
Always

Comment 1 Féliciano Matias 2004-10-03 17:40:59 UTC
Created attachment 104682 [details]
Fix for symlink handling.
The patch apply to a patched udev (rh patchs).

Fix for symlink handling.
Check it carefully. All I can say, is that it works for me.

Comment 2 Harald Hoyer 2004-10-04 12:35:01 UTC
Please post your patches to linux-hotplug-devel@lists.sourceforge.net

Comment 3 Féliciano Matias 2004-10-04 13:01:11 UTC
My current patch does not apply to a vanilla udev.
Which patch from udev-032-7 can I expect to be upstream ?

Should I recreate the patch again a vanilla udev ?

Comment 4 Harald Hoyer 2004-10-04 13:10:43 UTC
yes, please... I will include your patch in the next udev.


Note You need to log in before you can comment on or make changes to this bug.