Bug 134486 - current backspace_deletes_character may fail openi18n L1
current backspace_deletes_character may fail openi18n L1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-03 21:08 EDT by Leon Ho
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-22 00:20:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leon Ho 2004-10-03 21:08:05 EDT
Description of problem:
Because of the backport of bug 132189, backspace now deletes vowel
instead of deleting the whole character. Hence it may fails on the
assertion at
http://www.openi18n.org/subgroups/testsuites/1.3/interactive/text-editor-tests/general-text-editor-test-scenario.html

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. Download UTF-8.txt
2. gedit UTF-8.txt
3. delete characters from
Basic Greek
Latin Extended Additional
Greek Extended
Hiragana
Hangul Extended

Actual results:
only delete the vowel

Expected results:
delete the whole char

Additional info:
or we may want to add a environment variable, conf setting or some
sort to enable/disable this behavior.
Comment 1 Owen Taylor 2004-10-04 11:22:43 EDT
See comments on the last bug report on this issue.
Comment 2 Leon Ho 2004-10-22 00:20:00 EDT
Fixed in rawhide. Those are not being delete on each component of
character anymore.

Note You need to log in before you can comment on or make changes to this bug.