Bug 134523 - rpm(1) doesn't install 32bit packages properly.
rpm(1) doesn't install 32bit packages properly.
Status: CLOSED DUPLICATE of bug 133873
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-04 08:22 EDT by L3support
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-10-04 08:22:56 EDT
Description of problem:
Several problems happen as we install ia32 rpm packages in ia64
environment. 
- rpm(1) donesn't relocate direcotries including files whose filecolor
is 1 to /emul/ia32-linux.
- pre or post processing errors are output in /root/install.log when
we  install RHEL4 beta1 with full installation.
  For example,
   error: %post(libgcc-3.4.1-10) scriptlet failed, exit status 255,
   error: %pre(dbus-0.22-4) scriptlet failed, exit status 255,
   error:   install: %pre scriptlet failed (2), skipping dbus-0.22-4,

Version-Release number of selected component (if applicable):
rpm-4.3.2-4

How reproducible:
always

Steps to Reproduce:
1. Install RHEL4 beta1 with full installation
after installation,
2. See '/' directory
3. See '/root/install.log' file
  
Actual results:
- /emul/ia32-linux doesn't exist
- There are several errors in /root/install.log 

Expected results:
- rpm(1) relocates the directories to /emul/ia32-linux.
- There are no errors in /root/install.log.

Additional info:
Comment 1 Jay Turner 2004-10-04 08:40:22 EDT

*** This bug has been marked as a duplicate of 133873 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.