Bug 134556 - D-Link DWL-520 wireless seen as a wired card
D-Link DWL-520 wireless seen as a wired card
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-04 12:14 EDT by Jamie Bohr
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 10:00:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamie Bohr 2004-10-04 12:14:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
The D-Link DWL-520 card is seen by the OS (FC3-test2) as a wired
network card; FC2 has the same issue.  I was told that kudz might be
the problem, but it was unclear if that was truely the root cause. 
The network configure utility sees the card as a Prism 2.5 ....

I was asked to place a bug in bugzilla so the developers would know
there is an issue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install the card
2.  Let kudzu find and configure the card
3.
    

Actual Results:  Bring up redhat-config-network-gui, the wireless card
will be listed as a wireed card.

Expected Results:  redhat-config-network-gui sees the card as wireless
card to wireless configuration can be done.

Additional info:
Comment 1 Bill Nottingham 2004-10-04 12:35:17 EDT
All network cards are classified as a single class in kudzu; there's
not much else to be done there.
Comment 2 Harald Hoyer 2004-10-05 04:37:06 EDT
what does:
# /sbin/iwconfig 

output?
Comment 3 Jamie Bohr 2004-10-05 10:16:18 EDT
# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

# 

system-config-network-gui sees the card as a "Intersil Corporation
Prism".  I tested FC 2, same issue.
Comment 4 Harald Hoyer 2004-10-05 11:43:48 EDT
could you try system-config-network-1.3.21, as soon as it appears on
rawhide?
Comment 5 Jamie Bohr 2004-11-19 08:06:36 EST
Sorry it took so long to reply, I was out.  After installing a fresh
copy of FC3 the wireless card, D-Link DWL-520, still shows up as a
wired card.  If you would like I can allow you to login so you can
look around.
Comment 6 Harald Hoyer 2004-11-19 10:00:11 EST
If 
# iwconfig

does not show any wirless extensions, you need to install the correct
kernel module for this card. As it seems there is none for the "D-Link
DWL-520" in FC3.
A fast google search with "D-Link DWL-520 linux" resulted in:
http://support.dlink.com/faq/view.asp?prod_id=357&question=General%20Wireless

So get the source and compile your driver... 

Note You need to log in before you can comment on or make changes to this bug.