Bug 134563 - Fails to build with 'ccache'
Summary: Fails to build with 'ccache'
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: valgrind   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-04 17:23 UTC by Enrico Scholz
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: valgrind-2.2.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 09:00:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2004-10-04 17:23:44 UTC
Description of problem:

valgrind fails to rebuild when ccache (http://ccache.samba.org/) is
activated:

| if gcc -DHAVE_CONFIG_H -I. -I. -I../..  -I../../coregrind -I../../coregrind -I../../include -I../../include   -Winline -Wall -Wshadow -O -fomit-frame-pointer -g -Wno-unused -MT cplus-dem.o -MD -MP -MF ".deps/cplus-dem.Tpo" -c -o cplus-dem.o cplus-dem.c; \
| then mv -f ".deps/cplus-dem.Tpo" ".deps/cplus-dem.Po"; else rm -f ".deps/cplus-dem.Tpo"; exit 1; fi
| make[4]: *** [cplus-dem.o] Error 1


This is caused by the 'env - ' trick which works around a bug in
make<3.80. With recent make version this is not required
anymore. Alternatively, a not so intrusive

| unset CFLAGS

could be used (CFLAGS was the responsible variable).



Version-Release number of selected component (if applicable):

valgrind-2.2.0-2
make-3.80-4


Note You need to log in before you can comment on or make changes to this bug.