Bug 134569 - Graphical Install fails on Intel i815 chipset
Summary: Graphical Install fails on Intel i815 chipset
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-04 17:56 UTC by Phillip Sorensen
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: RHEL4 U2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 21:50:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Phillip Sorensen 2004-10-04 17:56:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10

Description of problem:
When trying to do a network install from directories created off the
RHEL 4 Beta1 CD's, the installed gets through the text part of the
installation.

When I get the message anaconda starting, my monitor (Mitsubishi
Diamond Pro 710s) and graphic chipset (i815) are detected correctly. 
When the switch is made to graphical mode, the screen fills with
bright graphical garbage. I can see the cursor for a brief second on
startup.



NOTE:  I have successfully installed from this CD set in a vmware
virtual machine without problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot on my machine with an Intel 815 chipset
2. Wait for the graphical part of the install

    

Actual Results:  A screen full of grabage.

Expected Results:  The graphical install screen

Additional info:

Comment 1 Phillip Sorensen 2004-10-04 18:18:34 UTC
More information:

After the text install failed for a different reason. I missed the
command line, and the installer booted fine into the graphical mode. 
I looked a little bit more.  What I seem to be seeing is this:

1. If I reboot by pressing the reset button, the graphical install
hangs with grabage on the screen.

2. If I enter rescue mode and let the software cause the reboot, I can
install in graphical mode fine. 

Comment 2 Jeremy Katz 2004-10-04 18:40:15 UTC
This sounds like a BIOS or X bug

Comment 3 Phillip Sorensen 2004-10-14 20:23:53 UTC
Looks like this could be a problem with the machine I'm using.  I
tried installing RHEL 3 AS back on the machine (which I have done in
the past with no problem) a have had even worse problems.

May not be a software bug.

Comment 4 Phillip Sorensen 2004-10-14 20:27:54 UTC
I must have acidentally clicked on the revolsed radio box when
submitting the above comment. I have reopen the bug

Comment 5 Mike A. Harris 2005-02-01 08:32:08 UTC
X.Org X11 (xorg-x11) is the X11 implementation in RHEL4, which
has replaced XFree86 from previous OS releases.

Reassigning to "xorg-x11" component.

Comment 6 Mike A. Harris 2005-02-01 08:35:22 UTC
This appears to be the infamous i810 "refresh" bug which was
present in Fedora Core 3, and early RHEL4 builds.  This issue
is resolved in our current rawhide xorg-x11, and is believed
to also be resolved in the final RHEL4 xorg-x11 as well.

Setting status to "MODIFIED".  If the official RHEL4 xorg-x11
does not resolve this issue, please set the status back to
"ASSIGNED" and update the report with any relevant details, and
we will re-examine the issue.

Thanks in advance.

Comment 7 Phillip Sorensen 2005-11-08 20:09:31 UTC
The release of RHEL-4 seems to resolve this issue.  I have install a couple
times in graphics mode. 


Note You need to log in before you can comment on or make changes to this bug.