Bug 134577 - Smartd service fails to start on boot every time.
Summary: Smartd service fails to start on boot every time.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: smartmontools (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-04 19:01 UTC by Kevin Olemoh
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version: FC-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-16 11:53:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/init.d/cpuspeed (1.54 KB, text/plain)
2004-11-02 12:43 UTC, Kay Sievers
no flags Details
smartd debug output (514 bytes, application/octet-stream)
2004-11-20 21:12 UTC, Kevin Olemoh
no flags Details
my smartd config file (84 bytes, text/plain)
2004-11-20 21:14 UTC, Kevin Olemoh
no flags Details

Description Kevin Olemoh 2004-10-04 19:01:37 UTC
Description of problem:
Smartd always fails during the boot process system appears to function
as it should however.

Version-Release number of selected component (if applicable):


How reproducible:

Always 
Steps to Reproduce:
1. Turn machine on and boot Fedora
2. Run through boot process as normal
3.
  
Actual results:
Smartd fails to start

Expected results:
I would expect the service to start instead of failing every time.

Additional info:

Comment 1 Kevin Olemoh 2004-10-04 19:04:02 UTC
This problem probably isn't related to this component but there is no
"other" option.

Comment 2 Rodger Wang 2004-10-12 11:41:48 UTC
I have exactly the same issue, and it persists in the lastest FC3T3
release.

Comment 3 Kay Sievers 2004-11-02 12:43:42 UTC
Created attachment 106065 [details]
/etc/init.d/cpuspeed

Comment 4 Bruce Allen 2004-11-02 12:50:15 UTC
Kay, what is the relevance of the cpuspeed init script to smartd startup?

Comment 5 Sitsofe Wheeler 2004-11-20 12:48:50 UTC
What sort of hard disks do you have? IDE/SCSI? If they are IDE are
they SATA?

Comment 6 Kevin Olemoh 2004-11-20 12:54:03 UTC
I have IDE drives, no SATA's yet.

Comment 7 Bruce Allen 2004-11-20 15:23:03 UTC
Please do the following (as root):

/usr/sbin/smartd --debug

and then post the output as an attachment.  Also please post
/etc/smartd.conf

Comment 8 Kevin Olemoh 2004-11-20 21:12:03 UTC
Created attachment 107128 [details]
smartd debug output

Comment 9 Kevin Olemoh 2004-11-20 21:14:55 UTC
Created attachment 107129 [details]
my smartd config file

Comment 10 Bruce Allen 2004-11-20 21:35:39 UTC
Both the config file and the smartd --debug output look 100% normal
and correct.  Please post the contents from /var/log/messages when you do
/etc/init.d/smartd restart
(as root).

Comment 11 Kevin Olemoh 2004-11-21 22:06:24 UTC
Well in truth I have not noticed a smartd failure since I upgraded to
fc3 I think whatever the problem was was already handled, I'll get
back to you with that output later on if you still want to see it.

Comment 12 kaushik 2005-09-15 20:08:19 UTC
Hi im also facing the similar problem btw im using FC4

Comment 13 Tomas Mraz 2005-11-16 11:53:43 UTC
Well it seems that the original bug disappeared after upgrade to FC3.


Note You need to log in before you can comment on or make changes to this bug.