Bug 134646 - After installing, RHEL 4beta1 fails to boot from ext2 root fs
After installing, RHEL 4beta1 fails to boot from ext2 root fs
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 08:38 EDT by Barry K. Nathan
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 01:28:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
retyped screenshot (including scrollback buffer) of screen after failure (1.56 KB, text/plain)
2004-10-05 08:48 EDT, Barry K. Nathan
no flags Details
install.log.syslog (from minimal install to ext2 filesystem) (2.81 KB, text/plain)
2004-10-05 21:58 EDT, Barry K. Nathan
no flags Details

  None (edit)
Description Barry K. Nathan 2004-10-05 08:38:54 EDT
Description of problem:
When I install RHEL 4 beta 1 (nahant beta 1) WS on an ext2 root
filesystem, the resulting system fails on its first reboot.

Version-Release number of selected component (if applicable):
nahant beta 1 WS

How reproducible:
Always

Steps to Reproduce:
1. Boot the installer, and start an installation from hard drive.
2. Manually partition: Do not use LVM, do not set up a /boot
partition, and set up / as ext2 not ext3.
3. Install the default package selection, or install Everything (both
of those configurations reproduced the bug for me).
4. Let the install finish.
5. Click "Reboot", and attempt to boot the installed system.
  
Actual results:
Everything seems fine until the graphical boot stuff comes up. Then
things are fine until (I think) "Setting host name". After that, it
spends a minute or two banging the disk (the orange light stays pretty
brightly lit), then it bails out from the graphical boot to a text
prompt. I'll re-type at least the lower half of the screen -- maybe
the whole screen -- as an additional comment to this bug (or maybe
even as an attachment rather than a comment).

Expected results:
System should boot, and I should get a login prompt.

Additional info:
I've actually been seeing weird stuff happen with fscks on FC2-test
(and later) installs that have SELinux installed, but this is the
first time it's been easily reproducible.
Comment 1 Barry K. Nathan 2004-10-05 08:48:24 EDT
Created attachment 104780 [details]
retyped screenshot (including scrollback buffer) of screen after failure

There could be typos here because I retyped this by hand, but hopefully I
didn't make any...
Comment 2 Barry K. Nathan 2004-10-05 08:51:39 EDT
I forgot to mention, I haven't tried typing the root password in
there. If I hit Control-D, the system outputs approx. 4 lines of text
and, after a few seconds, reboots.

I'm now trying a reboot into the fsck'd filesystem, and this time it's
getting all the way to firstboot. However, why would anaconda (or
whoever the guilty party is) leave the filesystem dirty? Hardware is a
Western Digital WD800BB hard drive on an SiS IDE controller. (If you
need more detailed info than that, let me know and I'll provide it.)
Comment 3 Jeremy Katz 2004-10-05 12:29:05 EDT
Is this reproducible?  When the installer rebooted, were there any
error messages about being unable to unmount a filesystem?
Comment 4 Barry K. Nathan 2004-10-05 19:52:06 EDT
This is 100% reproducible, absolutely. I don't recall seeing any
messages about being unable to unmount a filesystem, but I don't think
I looked closely enough. I think I'll try to reproduce this again in
the next few minutes so that I can look more closely.
Comment 5 Barry K. Nathan 2004-10-05 21:48:02 EDT
Never mind, there *are* messages about failed umounts. Paraphrasing:

...
/mnt/sysimage/dev/pts (error 22)
...
/mnt/sysimage (error 16)
...
Comment 6 Barry K. Nathan 2004-10-05 21:58:17 EDT
Created attachment 104818 [details]
install.log.syslog (from minimal install to ext2 filesystem)

I forgot to mention in my previous comment that the problem occurs with Minimal
installs (i.e. in addition to the standard package set or Everything).

Anyway, this is the install.log.syslog from a minimal install, in case that has
any hints.

I can attach install.log too if you want, but it's boring. Trimmed version:

---begin quote---
Installing 279 packages:

Installing hwdata-0.131-1.noarch.
[snip...]
Installing comps-3.94WS-0.20040920.i386.
 
 
The following packages were available in this version but NOT installed:
4Suite-1.0-2.i386.rpm
[snip...]
zsh-html-4.2.0-3.i386.rpm
---end quote---
Comment 7 Jeremy Katz 2004-10-05 22:23:01 EDT
Hmm... and no attempt to unmount /mnt/sysimage/dev?  Bet that's the
problem.

Off to read that code again and see how it breaks with bind mounts
being used :)
Comment 8 Barry K. Nathan 2004-10-05 22:32:59 EDT
I don't know whether there was an attempt to unmount
/mnt/sysimage/dev. I'll have to look at it again. (It goes by *way*
too fast for me to copy down the entire list of umounted filesystems.)

I tried all of the following, and the problem persists:

- selinux=0
- NFS image install (i.e. from an NFS server with the ISO images)
rather than a hard drive install
- choosing to install no bootloader rather than GRUB
Comment 9 Barry K. Nathan 2004-10-05 22:52:48 EDT
A more complete paraphrase of what's happening when it's umounting
filesystems:

...
/mnt/sysimage/dev/pts (error 22)
... [other /mnt/sysimage/* filesystems, e.g. /mnt/sysimage/proc]
/mnt/sysimage/dev done
/mnt/sysimage (error 16)
...
Comment 10 Jeremy Katz 2004-10-06 13:52:20 EDT
Hmm... this is working for me on a current tree, but it could be that
I've changed something since beta1 that makes it work. 

Could you try with a current Fedora devel tree and see if it's better
there?  The bits should be basically the same (except newer :) and if
it's fine there, then it should be fixed for RHEL4 as well.
Comment 11 Barry K. Nathan 2004-10-06 15:09:15 EDT
Ok, I'll go ahead and try with fc-devel sometime later today. (It may
be several hours before I get a chance. On the bright side, at least I
have the latest fc-devel snapshot downloaded already.)
Comment 12 Barry K. Nathan 2004-10-07 01:28:31 EDT
A 20041006 fc-devel snapshot does not have this problem, so I'm
closing this as RAWHIDE. I'll retest this when nahant beta2 comes out
and reopen it then if it's still a problem.

Note You need to log in before you can comment on or make changes to this bug.