Bug 1346681 - RFE: plugin that would consider explicitly removed packages by user and don;t pulled them in as weak deps during update
Summary: RFE: plugin that would consider explicitly removed packages by user and don;t...
Keywords:
Status: CLOSED DUPLICATE of bug 1278196
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 24
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1394211 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-15 07:51 UTC by Thorsten Leemhuis
Modified: 2016-11-14 12:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-31 15:05:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Thorsten Leemhuis 2016-06-15 07:51:57 UTC
Description of problem:
I'm running my system with LANG=de_DE.utf8, but don't want to see man pages written in German, as they sometimes are badly translated or outdated. Until F24 I could easily arrange for that by running "rpm -e man-pages-de" or "dnf remove man-pages-de". In F24 that doesn't work anymore, as man-pages-de gets reinstalled every time man-pages receives an update (just happened to me and verified be downgrading and updating again). That's due to this afaics:
 
$ rpm -qp man-pages-de-1.12-3.fc24.noarch.rpm --supplements
(man-pages and langpacks-de)

I wonder if dnf should somehow work like this "hey, the user on purpose uninstalled man-pages-de earlier, so lets not reinstall it now while updating mang-pages, even if the supplements tag suggests to do it".

Version-Release number of selected component (if applicable):
dnf-1.1.9-2.fc24.noarch
python3-dnf-1.1.9-2.fc24.noarch
libsolv-0.6.22-1.fc24.x86_64
hawkey-0.6.3-2.fc24.x86_64

Comment 1 Raphael Groner 2016-06-15 08:18:45 UTC
What update, this latest?
https://bodhi.fedoraproject.org/updates/FEDORA-2016-1b4243e1a8

Comment 2 Thorsten Leemhuis 2016-06-15 08:20:59 UTC
(In reply to Raphael Groner from comment #1)
> What update, this latest?
> https://bodhi.fedoraproject.org/updates/FEDORA-2016-1b4243e1a8

Yes. But In the end it's just the update to the package "man-pages" afaics. I verified by downgrading to the older man-pages package locally and running "dnf update" again.

Comment 3 Parag Nemade 2016-06-15 11:41:29 UTC
I confirm I can reproduce this bug today as I know man-pages-de update is available and I removed man-pages-de before executing "dnf update".

Let's see what dnf developers have to say on this issue.

Comment 4 Honza Silhan 2016-06-20 11:25:49 UTC
We can make plugin that would not pulled in removed weak deps.
at the meantime you can add into "excludes" in dnf.conf "man-pages-de".

Comment 5 Fedora Admin XMLRPC Client 2016-07-08 09:32:39 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 6 Vít Ondruch 2016-10-31 15:00:03 UTC
(In reply to Honza Silhan from comment #4)
> We can make plugin that would not pulled in removed weak deps.
> at the meantime you can add into "excludes" in dnf.conf "man-pages-de".

This is probably not enough. The "excludes" should support pairs of packages, e.g. if there is required installation/update of package A, which has weak dependency on package B, please ignore B. However, if there is package C, which has dependency (hard or soft, it doesn't really matters) on B, the B should be installed.

BTW this seems to be duplicate of bug 1278196

Comment 7 Igor Gnatenko 2016-10-31 15:05:53 UTC

*** This bug has been marked as a duplicate of bug 1278196 ***

Comment 8 Igor Gnatenko 2016-11-14 12:34:56 UTC
*** Bug 1394211 has been marked as a duplicate of this bug. ***

Comment 9 Harald Reindl 2016-11-14 12:48:05 UTC
no, B should not be installed when it is a weak dependency which was manually removed - in no case - when i say "dnf remove" i mean "dnf remove" until i say the opposite or something introdcues a hard-dependency


Note You need to log in before you can comment on or make changes to this bug.