Bug 134673 - (xinitrc-apocalypse) xinitrc missing closing "fi" in if block
xinitrc missing closing "fi" in if block
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 134690 134711 134726 134756 134761 134771 134840 134880 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 11:29 EDT by Sammy
Modified: 2007-11-30 17:10 EST (History)
9 users (show)

See Also:
Fixed In Version: xinitrc-4.0.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-06 00:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2004-10-05 11:29:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; en_US) (KHTML, like Gecko)

Description of problem:
When I upgrade to 4.0.7 from 4.0.5 I could not login as an ordinary
user via kde. I type in the username/password the session starts but
suddenly it exits and gives me the kdm screen again. I can login as
root without any problems. Downgrading to 4.0.5 solves the problem.

I tried locating the problem but failed...Xsession and xinitrc seemed
ok. I could also use these scripts with 4.0.5 to login (restarting X always).
To the life of me I can't see what it going on.
FYI

Version-Release number of selected component (if applicable):
xinitrc-4.0.7

How reproducible:
Always

Steps to Reproduce:
1.Upgrade to xinitrd 4.0.7
2.try to login via kdm
3.
    

Additional info:
Comment 1 Tim Vismor 2004-10-05 11:38:42 EDT
I had this problem also. It appears to be caused by modifications to
/etc/X11/xinit/Xclients that resulted in a syntax error. More
specifically, a "fi" is missing in the first if block:

PREFERRED=
if [ -f /etc/sysconfig/desktop ]; then
    . /etc/sysconfig/desktop
    if [ "$DESKTOP" = "GNOME" ]; then
	PREFERRED=gnome-session
    elif [ "$DESKTOP" = "KDE" ]; then
	PREFERRED=startkde
+   fi          <--------------------------
fi
Comment 2 Clyde E. Kunkel 2004-10-05 11:56:25 EDT
Similar problem.  After today's rawhide update when logging in as my
usual user got error dialogue "Your session only lasted 10
seconds...." The details were:
1. /etc/Xll/gdm/PreSession/Default: Registering your session with wtmp
and utemp
2. /etc/Xll/gdm/PreSession/Default: running: /usr/bin/Xll/sessreg -a
-w /var/log/wtmp -u /var/run/utmp -x :var/ggm/:0.Xservers" -h "" -l
":0" "kunkelc"
3. /etc/Xll/xinit/Xclients: line 69: syntax error: unexpected end of file

fixed by going to tty2, logging in as usual user and running
switchdesk kde, exited, back to gdm, log in to kde, logout, go to
tty2, return to gnome, log back in...all well at this point except
evolution quit during this entry.  Going to investigate that now.

All probs follow todays rawhide.  Running kernel .541smp
Comment 3 Scott Talbot 2004-10-05 23:06:09 EDT
*** Bug 134726 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2004-10-06 00:10:19 EDT
*** Bug 134690 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2004-10-06 00:11:46 EDT
*** Bug 134711 has been marked as a duplicate of this bug. ***
Comment 6 Mike A. Harris 2004-10-06 00:24:46 EDT
Thanks for bringing this to our attention.  xinitrc has had
a number of semi-major changes and cleanups lately, and I
suspected there might have been a few glitches and gotchas
here and there.  ;o)

I've added a fix for this to xinitrc-4.0.10-1, which is built
in rawhide now.  Once you've had a chance to test the new
package, if you discover any other problems, please file
new bugs in bugzilla and we'll try to fix them ASAP to maximize
test coverage and stability due to the recent package churn.

Thanks again.
Comment 7 Bill Nottingham 2004-10-06 00:30:13 EDT
*** Bug 134756 has been marked as a duplicate of this bug. ***
Comment 8 Mike A. Harris 2004-10-06 08:36:20 EDT
*** Bug 134771 has been marked as a duplicate of this bug. ***
Comment 9 Mike A. Harris 2004-10-06 08:52:17 EDT
*** Bug 134761 has been marked as a duplicate of this bug. ***
Comment 10 Mike A. Harris 2004-10-06 15:04:05 EDT
*** Bug 134840 has been marked as a duplicate of this bug. ***
Comment 11 Mike A. Harris 2004-10-06 20:30:40 EDT
*** Bug 134880 has been marked as a duplicate of this bug. ***
Comment 12 Mike A. Harris 2004-10-06 20:36:43 EDT
Status update:

While xinitrc-4.0.10-1 fixes the problem described in this bug
report, and all of the duplicate bug reports, there were some
other unrelated bugs in xinitrc in the last week or so which
have also been fixed since then.  The current release of xinitrc
is 4.0.13-1, which fixes all known xinitrc related issues.

If anyone has any xinitrc related problems still, please make
sure you are using version 4.0.13-1 before reporting new bugs,
as this fixes all known issues that many people have been
hitting.

The new xinitrc-4.0.13-1 will be in rawhide tomorrow or the
next day, however in the mean time, you can obtain it from the
following URL via ftp:

ftp://people.redhat.com/mharris/testing/unstable/xinitrc/4.0.13-1/noarch/xinitrc-4.0.13-1.noarch.rpm

Thanks everyone for testing Fedora Core development and for
reporting these issues to us.  If you find any new problems
in the new package, please report them in new bug reports, and
we'll try to have them fixed as soon as possible.

Take care!

Note You need to log in before you can comment on or make changes to this bug.