Bug 134675 - gcc-3;4;2-4 gives internal compiler error
gcc-3;4;2-4 gives internal compiler error
Status: CLOSED DUPLICATE of bug 134676
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 11:35 EDT by Sammy
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2004-10-05 11:35:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; en_US) (KHTML, like Gecko)

Description of problem:
After upgrading this morning and trying to build one of the kde rpms
with updated sources I gor an internal compiler error and segfault,
with some message about reporting this bug.

Downgrading to 3.4.2-2 does not have this problem. Here is the actual
text of the error:
 ====================================================

/bin/sh ../libtool --silent --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -I. -I. -I..  -D_LARGEFILE64_SOURCE -I/usr/include/kde -I/usr/lib/qt-3.3/include -I/usr/X11R6/include  -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -O2 -O2 -g -pipe -m32 -march=i386 -mtune=pentium4 -DNDEBUG -DNO_DEBUG -fno-use-cxa-atexit -fno-check-new -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -c -o tar.lo `test -f 'tar.cpp' || echo './'`tar.cpp
In file included from /usr/include/kde/kservicetype.h:24,
                 from /usr/include/kde/kmimetype.h:35,
                 from tar.cpp:60:
/usr/include/kde/ksycocaentry.h: In constructor `KSycocaEntry::KSycocaEntry(QDataStream&,int)':
/usr/include/kde/ksycocaentry.h:66: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccfdJCH9.out file, please attach this to your bugreport.
=================================================

Version-Release number of selected component (if applicable):
gcc-3.4.2-4

How reproducible:
Always

Steps to Reproduce:
1.upgrade ro 3.4.2-4
2.try to build kdeutils-3.3.1 rpm
3.segfaults in ark build
    

Additional info:
Comment 1 Jakub Jelinek 2004-10-05 12:57:01 EDT

*** This bug has been marked as a duplicate of 134676 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.