Bug 134690 - Xclients file missing a line in latest package (4.0.7-1)
Xclients file missing a line in latest package (4.0.7-1)
Status: CLOSED DUPLICATE of bug 134673
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 12:28 EDT by Ryan Skadberg
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Skadberg 2004-10-05 12:28:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041002
Firefox/0.10.1

Description of problem:
In the latest Xclients file an fi is missing that causes you not to be
able to log in.

In the block trying to figure out PREFERRED it has:

if [ -f /etc/sysconfig/desktop ]; then
    . /etc/sysconfig/desktop
    if [ "$DESKTOP" = "GNOME" ]; then
        PREFERRED=gnome-session
    elif [ "$DESKTOP" = "KDE" ]; then
        PREFERRED=startkde
fi


This should be:

if [ -f /etc/sysconfig/desktop ]; then
    . /etc/sysconfig/desktop
    if [ "$DESKTOP" = "GNOME" ]; then
        PREFERRED=gnome-session
    elif [ "$DESKTOP" = "KDE" ]; then
        PREFERRED=startkde
    fi
fi

Note the fi after the startkde line.


Version-Release number of selected component (if applicable):
xinitrc-4.0.7-1

How reproducible:
Always

Steps to Reproduce:
1. startx or try to log in from XDM


Actual Results:  Not able to start X session

Expected Results:  X logs in correctly

Additional info:
Comment 1 Andrew Farris 2004-10-05 16:40:18 EDT
Also bug: #134673 #134711 #134726
Comment 2 Mike A. Harris 2004-10-06 00:10:10 EDT

*** This bug has been marked as a duplicate of 134673 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.